summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-07-17 20:29:41 +0200
committerHans de Graaff <graaff@gentoo.org>2024-07-18 08:05:03 +0200
commit5e1f85e8a8632c691c4d2ab6ded271e3edeb3b83 (patch)
tree37e044fe3d2bbb3e24464cf92453b2a397b292a8
parentdev-ruby/omniauth: drop 2.1.1 (diff)
downloadgentoo-5e1f85e8a8632c691c4d2ab6ded271e3edeb3b83.tar.gz
gentoo-5e1f85e8a8632c691c4d2ab6ded271e3edeb3b83.tar.bz2
gentoo-5e1f85e8a8632c691c4d2ab6ded271e3edeb3b83.zip
dev-ruby/omniauth: use compatible rack-protection slot
Only rack-protection:3 is compatible with the version of rack that we require here. Closes: https://bugs.gentoo.org/936203 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/omniauth/omniauth-2.1.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-ruby/omniauth/omniauth-2.1.2.ebuild b/dev-ruby/omniauth/omniauth-2.1.2.ebuild
index 0ff88ca09fd5..84c249a9576a 100644
--- a/dev-ruby/omniauth/omniauth-2.1.2.ebuild
+++ b/dev-ruby/omniauth/omniauth-2.1.2.ebuild
@@ -16,22 +16,23 @@ DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
HOMEPAGE="https://github.com/omniauth/omniauth"
SRC_URI="https://github.com/omniauth/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="~amd64"
+
SLOT="$(ver_cut 1)"
-IUSE=""
+KEYWORDS="~amd64"
+IUSE="doc test"
ruby_add_rdepend "
>=dev-ruby/rack-2.2.3
dev-ruby/rack-protection
>=dev-ruby/hashie-3.4.6:*"
ruby_add_bdepend "doc? ( dev-ruby/yard )
- test? ( dev-ruby/rack-test dev-ruby/rack:2.2 )"
+ test? ( dev-ruby/rack-test dev-ruby/rack:2.2 dev-ruby/rack-protection:3 )"
all_ruby_prepare() {
sed -i -e '/[Bb]undler/d' \
Rakefile ${PN}.gemspec || die "sed failed"
sed -e '/RUBY_VERSION/,/^end/ s:^:#: ; /freeze/ s:^:#:' \
- -e '2igem "rack", "<3"' \
+ -e '2igem "rack", "<3"; gem "rack-protection", "~> 3.0"' \
-e '/simplecov/,/^end/ s:^:#:' \
-i spec/helper.rb || die "sed failed"
# maruku fails, resorting to default markdown implementation