summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:13:51 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:00 +0100
commit583435fc464ebc2da363b659aa8ed2e38333ad52 (patch)
tree7bea42c69ac140188f21981b8ee09fd67c45ef36
parentnet-analyzer/zabbix: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-583435fc464ebc2da363b659aa8ed2e38333ad52.tar.gz
gentoo-583435fc464ebc2da363b659aa8ed2e38333ad52.tar.bz2
gentoo-583435fc464ebc2da363b659aa8ed2e38333ad52.zip
net-dialup/xl2tpd: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild4
-rw-r--r--net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild
index 672c9d925083..1bfcb77b0089 100644
--- a/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.15.ebuild
@@ -46,3 +46,7 @@ src_install() {
insopts -m 0600
newins doc/l2tp-secrets.sample l2tp-secrets
}
+
+pkg_postinst() {
+ tmpfiles_process xl2tpd.conf
+}
diff --git a/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild b/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
index a1825dcc1a53..5821a9c07fe3 100644
--- a/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
+++ b/net-dialup/xl2tpd/xl2tpd-1.3.16.ebuild
@@ -46,3 +46,7 @@ src_install() {
insopts -m 0600
newins doc/l2tp-secrets.sample l2tp-secrets
}
+
+pkg_postinst() {
+ tmpfiles_process xl2tpd.conf
+}