summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2024-06-08 18:25:11 -0600
committerSam James <sam@gentoo.org>2024-07-04 02:16:38 +0100
commit3fa0318cd3aabc9fbc7aeeca8300f98c16b57ca2 (patch)
tree0fd0ef54321fffdd10cf6ee8bfc89b5e2db93f14
parentgui-wm/dwl: sync keywords in live ebuilds (diff)
downloadgentoo-3fa0318cd3aabc9fbc7aeeca8300f98c16b57ca2.tar.gz
gentoo-3fa0318cd3aabc9fbc7aeeca8300f98c16b57ca2.tar.bz2
gentoo-3fa0318cd3aabc9fbc7aeeca8300f98c16b57ca2.zip
gui-wm/dwl: stop using SLOT/SUBSLOT to depend on gui-libs/wlroots
Closes: https://bugs.gentoo.org/933717 Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--gui-wm/dwl/dwl-9999-r1.ebuild13
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild13
2 files changed, 18 insertions, 8 deletions
diff --git a/gui-wm/dwl/dwl-9999-r1.ebuild b/gui-wm/dwl/dwl-9999-r1.ebuild
index dd4f5c714b7a..64c73b5b8ef2 100644
--- a/gui-wm/dwl/dwl-9999-r1.ebuild
+++ b/gui-wm/dwl/dwl-9999-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,12 @@ EAPI=8
inherit savedconfig toolchain-funcs
MY_P="${PN}-v${PV}"
-WLROOTS_SLOT="0/18"
+
+WLROOTS_DEP="
+ >=gui-libs/wlroots-0.18:=[libinput,session,X?]
+ <gui-libs/wlroots-0.19:=
+"
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://codeberg.org/dwl/dwl.git"
inherit git-r3
@@ -19,7 +24,7 @@ if [[ ${PV} == *9999* ]]; then
;;
9999-r1)
EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
+ WLROOTS_DEP="~gui-libs/wlroots-9999:=[libinput,session,X?]"
;;
esac
else
@@ -36,9 +41,9 @@ SLOT="0"
IUSE="X"
RDEPEND="
+ ${WLROOTS_DEP}
dev-libs/libinput:=
dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[libinput,session,X?]
x11-libs/libxkbcommon
X? (
x11-libs/libxcb:=
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
index 9597cd86dc6b..11f48b8e090b 100644
--- a/gui-wm/dwl/dwl-9999.ebuild
+++ b/gui-wm/dwl/dwl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,12 @@ EAPI=8
inherit savedconfig toolchain-funcs
MY_P="${PN}-v${PV}"
-WLROOTS_SLOT="0/17"
+
+WLROOTS_DEP="
+ >=gui-libs/wlroots-0.17:=[libinput,session,X?]
+ <gui-libs/wlroots-0.18:=
+"
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://codeberg.org/dwl/dwl.git"
inherit git-r3
@@ -19,7 +24,7 @@ if [[ ${PV} == *9999* ]]; then
;;
9999-r1)
EGIT_BRANCH=wlroots-next
- WLROOTS_SLOT="0/9999"
+ WLROOTS_DEP="~gui-libs/wlroots-9999:=[libinput,session,X?]"
;;
esac
else
@@ -36,9 +41,9 @@ SLOT="0"
IUSE="X"
RDEPEND="
+ ${WLROOTS_DEP}
dev-libs/libinput:=
dev-libs/wayland
- gui-libs/wlroots:${WLROOTS_SLOT}[libinput,session,X?]
x11-libs/libxkbcommon
X? (
x11-libs/libxcb:=