summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-15 02:34:54 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-15 02:36:35 +0200
commit3c2955b86d47c5ad95e40295f2b400af491eed6b (patch)
treedb521a82b2cf2789a756dc1f133237da8507b1ca
parentdev-python/cython: backport tracing fix for python3_10 compatibility (diff)
downloadgentoo-3c2955b86d47c5ad95e40295f2b400af491eed6b.tar.gz
gentoo-3c2955b86d47c5ad95e40295f2b400af491eed6b.tar.bz2
gentoo-3c2955b86d47c5ad95e40295f2b400af491eed6b.zip
dev-python/cython: adapt IndentationError test to python3_10
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/cython/cython-0.29.23.ebuild1
-rw-r--r--dev-python/cython/files/cython-0.29.23-test_exceptions-py310.patch14
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/cython/cython-0.29.23.ebuild b/dev-python/cython/cython-0.29.23.ebuild
index d091b7190eb7..ef4189bc3f42 100644
--- a/dev-python/cython/cython-0.29.23.ebuild
+++ b/dev-python/cython/cython-0.29.23.ebuild
@@ -32,6 +32,7 @@ BDEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-0.29.14-sphinx-update.patch"
"${FILESDIR}/${PN}-0.29.22-spawn-multiprocessing.patch"
+ "${FILESDIR}/${PN}-0.29.23-test_exceptions-py310.patch"
"${FILESDIR}/${PN}-0.29.23-tracing-py310.patch"
)
diff --git a/dev-python/cython/files/cython-0.29.23-test_exceptions-py310.patch b/dev-python/cython/files/cython-0.29.23-test_exceptions-py310.patch
new file mode 100644
index 000000000000..0c9fb2c9ea56
--- /dev/null
+++ b/dev-python/cython/files/cython-0.29.23-test_exceptions-py310.patch
@@ -0,0 +1,14 @@
+--- a/tests/run/test_exceptions.pyx
++++ b/tests/run/test_exceptions.pyx
+@@ -188,7 +188,10 @@
+
+ # should not apply to subclasses, see issue #31161
+ s = '''if True:\nprint "No indent"'''
+- ckmsg(s, "expected an indented block", IndentationError)
++ if sys.version_info >= (3, 10):
++ ckmsg(s, "expected an indented block after 'if' statement on line 1", IndentationError)
++ else:
++ ckmsg(s, "expected an indented block", IndentationError)
+
+ s = '''if True:\n print()\n\texec "mixed tabs and spaces"'''
+ ckmsg(s, "inconsistent use of tabs and spaces in indentation", TabError)