summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-26 17:43:14 -0400
committerSam James <sam@gentoo.org>2024-05-27 00:11:04 +0100
commit3082a374769c47114474d34fde309dcfbeb7f5ad (patch)
tree5a9ef56acbf34fbebc5ccf74a6efd3e74c17aa97
parentsys-process/audit: add whitelist for false positive configure implicit decls (diff)
downloadgentoo-3082a374769c47114474d34fde309dcfbeb7f5ad.tar.gz
gentoo-3082a374769c47114474d34fde309dcfbeb7f5ad.tar.bz2
gentoo-3082a374769c47114474d34fde309dcfbeb7f5ad.zip
sys-apps/portage: backport more tweaks to implicit func. decl QA check
Bug: https://bugs.gentoo.org/906027 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/portage/files/0001-install-qa-checks.d-suppress-some-gnulib-implicit-co.patch55
-rw-r--r--sys-apps/portage/portage-3.0.64-r3.ebuild (renamed from sys-apps/portage/portage-3.0.64-r2.ebuild)0
2 files changed, 51 insertions, 4 deletions
diff --git a/sys-apps/portage/files/0001-install-qa-checks.d-suppress-some-gnulib-implicit-co.patch b/sys-apps/portage/files/0001-install-qa-checks.d-suppress-some-gnulib-implicit-co.patch
index 8844e5029f07..bc8e2f51fa57 100644
--- a/sys-apps/portage/files/0001-install-qa-checks.d-suppress-some-gnulib-implicit-co.patch
+++ b/sys-apps/portage/files/0001-install-qa-checks.d-suppress-some-gnulib-implicit-co.patch
@@ -1,8 +1,8 @@
-From 8256473c6a9fa93e7cf81c46fa920cd522507c21 Mon Sep 17 00:00:00 2001
+From 236a2c7081e2208c817f9a99f012bab0be3d70b2 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz93@gmail.com>
Date: Fri, 17 May 2024 01:52:53 -0400
-Subject: [PATCH] install-qa-checks.d: suppress some gnulib implicit configure
- declarations
+Subject: [PATCH 1/2] install-qa-checks.d: suppress some gnulib implicit
+ configure declarations
These happen in tons of GNU packages because of using gnulib, which
pulls in macros that check for some functionality and spit out an
@@ -38,5 +38,52 @@ index 7969dff17..adea7d405 100644
find_log_targets() {
--
-2.45.1
+2.44.1
+
+
+From e01d7fde23c4a0cc9f22e7b1ea28d3deff0331ae Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Tue, 21 May 2024 19:22:31 -0400
+Subject: [PATCH 2/2] install-qa-checks.d: suppress some gnulib implicit decls
+ on musl
+
+These happen in tons of GNU packages because of using gnulib's regex.m4
+specifically, which pulls in a macro that checks for some functionality
+and spit out many implicit function declaration errors if regex.h isn't
+GNU's specifically.
+
+The compile tests do fail either way, it's just very dirty in the logs.
+
+Bug: https://bugs.gentoo.org/906027
+Closes: https://github.com/gentoo/portage/pull/1327
+Signed-off-by: Eli Schwartz <eschwartz93@gmail.com>
+---
+ bin/install-qa-check.d/90config-impl-decl | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/bin/install-qa-check.d/90config-impl-decl b/bin/install-qa-check.d/90config-impl-decl
+index adea7d405..8768c99c6 100644
+--- a/bin/install-qa-check.d/90config-impl-decl
++++ b/bin/install-qa-check.d/90config-impl-decl
+@@ -58,6 +58,18 @@ add_default_skips() {
+ # also gnulib, but checks both linux/non-linux headers
+ MIN
+ )
++ if [[ ${CHOST} = *musl* ]]; then
++ QA_CONFIG_IMPL_DECL_SKIP+=(
++ # gnulib checks for functions that aren't available on musl.
++
++ # regex.m4 always emits these warnings, but they are noisy to fix
++ # and the check will correctly fail due to missing macros anyway.
++ re_set_syntax
++ re_compile_pattern
++ re_search
++ re_match
++ )
++ fi
+ }
+
+ find_log_targets() {
+--
+2.44.1
diff --git a/sys-apps/portage/portage-3.0.64-r2.ebuild b/sys-apps/portage/portage-3.0.64-r3.ebuild
index edec27b9f08b..edec27b9f08b 100644
--- a/sys-apps/portage/portage-3.0.64-r2.ebuild
+++ b/sys-apps/portage/portage-3.0.64-r3.ebuild