summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-24 15:23:13 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-24 17:39:33 -0400
commit1cb39e43ada0dd1439c06acecfc749446551b493 (patch)
tree7ee77b904cf0d9c86ea2bbe8bce97af522b259d9
parentsys-apps/kexec-tools: merge git & release versions (diff)
downloadgentoo-1cb39e43ada0dd1439c06acecfc749446551b493.tar.gz
gentoo-1cb39e43ada0dd1439c06acecfc749446551b493.tar.bz2
gentoo-1cb39e43ada0dd1439c06acecfc749446551b493.zip
sys-apps/kexec-tools: drop some old versions
-rw-r--r--sys-apps/kexec-tools/Manifest1
-rw-r--r--sys-apps/kexec-tools/files/kexec.init-2.0.4144
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.8.ebuild75
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.9-r1.ebuild71
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.9.ebuild75
5 files changed, 0 insertions, 366 deletions
diff --git a/sys-apps/kexec-tools/Manifest b/sys-apps/kexec-tools/Manifest
index 2958a551adec..6a702451e5de 100644
--- a/sys-apps/kexec-tools/Manifest
+++ b/sys-apps/kexec-tools/Manifest
@@ -1,3 +1,2 @@
DIST kexec-tools-2.0.4.tar.xz 271604 SHA256 e5f5ab00d746eb15b4714eca6a8ec5a1a86a62ce2bbdad1b3000161138a978c6 SHA512 2514f407d9150d2615dffc91a525fb28f159bef92b9543f9802e2618746b7d4c04137668ad8a8d8f0b75f68ed9057d09629ce736b6a061b5cf817b9d904f549e WHIRLPOOL 70ad298512e700cd1cdee7698e4fa68a769d91d3080d5d8387b8362ad49126ad68b0b6dbd1f13305958bdc988f805fa610e487682fd0eb5e4e9bcda0a9022627
-DIST kexec-tools-2.0.8.tar.xz 272648 SHA256 f3abe96fa0793e63936725a4471429f070039a1e81e605deb378747194a50c47 SHA512 94d715cdf779802308f5f8a0bdfae55c1798cc515fd322a490e8b5414763ab4fa924930022baa0689cd001c2431aef4f28f18b3c7b0b7000cdfaa1a159ad5251 WHIRLPOOL 8d13239e153dded9a98f847101d5581fed8e5a51a17961d6156f0135642e589b7e766ecaeef439fca2b69d4a2bc8e8d3f681a78f28d35acf03bc8d6c06f8ab9e
DIST kexec-tools-2.0.9.tar.xz 272728 SHA256 8ae34a9ceb76350954e1e1e3ca9ab51da15862bd5f2fd14392208e60fb454f71 SHA512 b58f8f0872f1a6a3a93bc67068d7035c4b39e985dafadc573585d92259ff289bf98d5a567293a5286668315ac2158b232919e0c6847fdefc68b7ecbcfab5109e WHIRLPOOL 840d9d17ce9facc131736ef52acabb03bcc6d21f671896ff5603bd8d6bd629519e169ca878a127b863235b236dafd3b29f598424b272f599503bb3f1a5f70050
diff --git a/sys-apps/kexec-tools/files/kexec.init-2.0.4 b/sys-apps/kexec-tools/files/kexec.init-2.0.4
deleted file mode 100644
index a7101efbd87e..000000000000
--- a/sys-apps/kexec-tools/files/kexec.init-2.0.4
+++ /dev/null
@@ -1,144 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-depend() {
- need localmount
-}
-
-image_path() {
- local x= kver=$(uname -r) karch=$(uname -m)
- BOOTPART="${BOOTPART:-/boot}"
- for x in "${KNAME:-bzImage}" vmlinuz \
- bzImage-${kver} vmlinuz-${kver} \
- kernel-genkernel-${karch}-${kver} \
- kernel-${kver} kernel-${karch}; do
- if [ -e "${BOOTPART}/${x}" ]; then
- echo "${BOOTPART}/${x}"
- return 0
- fi
- done
-
- return 1
-}
-
-initrd_path() {
- local x= kver=$(uname -r) karch=$(uname -m)
- BOOTPART="${BOOTPART:-/boot}"
- for x in "${INITRD:-initrd}" \
- initrd.img-${kver} initrd-${kver}.img \
- initrd-${kver} initramfs-${kver}.img \
- initramfs-genkernel-${karch}-${kver} ; do
- if [ -e "${BOOTPART}/${x}" ]; then
- echo "${BOOTPART}/${x}"
- return 0
- fi
- done
-
- return 1
-}
-
-mount_boot(){
- local ret
-
- [ -n ${DONT_MOUNT_BOOT} ] && return 1
- grep -q " ${BOOTPART:-/boot} " /proc/mounts && return 1
-
- BOOTPART="${BOOTPART:-/boot}"
- ebegin "Mounting ${BOOTPART}"
- mount "${BOOTPART}"; ret=$?
- eend ${ret}
- return ${ret}
-}
-
-load_image() {
- local ret
- if [ "${KNAME}" = "-" ]; then
- ebegin "Disabling kexec"
- kexec -u; ret=$?
- eend ${ret}
- return ${ret}
- fi
-
- BOOTPART="${BOOTPART:-/boot}"
- local img= initrd="$(initrd_path)" mounted=false initrdopt=
-
- if ! img="$(image_path)"; then
- if mount_boot; then
- if img="$(image_path)"; then
- mounted=true
- initrd="$(initrd_path)"
- else
- eerror "No kernel image found in ${BOOTPART}!"
- umount "${BOOTPART}"
- return 1
- fi
- else
- eerror "No kernel image found in ${BOOTPART}!"
- return 1
- fi
- fi
-
- if [ -n "${INITRD}" ] && \
- ! [ "${INITRD}" = "${initrd}" ]; then
- eerror "Requested initrd: ${INITRD}"
- eerror "could not be found"
- return 1
- fi
-
- [ -n "${ROOTPART}" ] || \
- ROOTPART="$(readlink -f "$(sed -n '/^\/[^ ]* \/ / s,^\([^ ]*\).*,\1,p' /proc/mounts)")"
-
- [ -n "${KPARAM}" ] || KEXEC_OPT_ARGS="${KEXEC_OPT_ARGS} --reuse-cmdline"
-
- [ -n "${initrd}" ] && [ -e "${initrd}" ] && initrdopt="--initrd=${initrd}"
-
- local msg=
- [ -n ${initrd} ] && \
- msg="with ${initrd}"
- einfo "Using kernel image ${img} ${msg} for kexec"
-
- ebegin "Setting kexec with ${KEXEC_OPT_ARGS} -l ${img} root=${ROOTPART} ${KPARAM} ${initrdopt}"
- kexec ${KEXEC_OPT_ARGS} -l "${img}" --append="root=${ROOTPART} ${KPARAM}" ${initrdopt}
- local res=$?
-
- ${mounted} && umount "${BOOTPART}"
- eend ${res}
- return ${res}
-}
-
-start() {
- if [ "${LOAD_DURING_SHUTDOWN:-yes}" = "yes" ]; then
- if ! image_path > /dev/null; then
- ewarn "Cannot find kernel image!"
- ewarn "Please make sure a valid kernel image is present before reboot."
- return 0
- fi
- else
- ebegin "Configuring kexec"
- load_image
- eend $?
- fi
-}
-
-stop() {
- [ "${LOAD_DURING_SHUTDOWN:-yes}" != "yes" ] && return 0
-
- if ! yesno $RC_REBOOT; then
- einfo "Not rebooting, so disabling"
- kexec -u
- return 0
- fi
-
- if [ -f /nokexec ]; then
- einfo "Not using kexec during reboot"
- rm -f /nokexec
- kexec -u
- return 0
- fi
-
- ebegin "Configuring kexec"
- load_image
- eend $?
-}
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.8.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.8.ebuild
deleted file mode 100644
index f3d29ffbc780..000000000000
--- a/sys-apps/kexec-tools/kexec-tools-2.0.8.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools-utils flag-o-matic linux-info systemd
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
-SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="booke lzma xen zlib"
-
-REQUIRED_USE="lzma? ( zlib )"
-
-DEPEND="
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~KEXEC"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
- "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
- )
-
-pkg_setup() {
- # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
- export ASFLAGS="${CCASFLAGS}"
- # to disable the -fPIE -pie in the hardened compiler
- if gcc-specs-pie ; then
- filter-flags -fPIE
- append-ldflags -nopie
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with booke)
- $(use_with lzma)
- $(use_with xen)
- $(use_with zlib)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- dodoc "${FILESDIR}"/README.Gentoo
-
- newinitd "${FILESDIR}"/kexec.init-2.0.4-r2 kexec
- newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
-
- insinto /etc
- doins "${FILESDIR}"/kexec.conf
-
- insinto /etc/kernel/postinst.d
- doins "${FILESDIR}"/90_kexec
-
- systemd_dounit "${FILESDIR}"/kexec.service
-}
-
-pkg_postinst() {
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "For systemd support the new config file is"
- elog " /etc/kexec.conf"
- elog "Please adopt it to your needs as there is no autoconfig anymore"
- fi
-}
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.9-r1.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.9-r1.ebuild
deleted file mode 100644
index b8bd5e7baa6d..000000000000
--- a/sys-apps/kexec-tools/kexec-tools-2.0.9-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools-utils linux-info systemd
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
-SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="booke lzma xen zlib"
-
-REQUIRED_USE="lzma? ( zlib )"
-
-DEPEND="
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~KEXEC"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
- "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
- "${FILESDIR}"/${PN}-2.0.9-hardened.patch
-)
-
-pkg_setup() {
- # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
- export ASFLAGS="${CCASFLAGS}"
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with booke)
- $(use_with lzma)
- $(use_with xen)
- $(use_with zlib)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- dodoc "${FILESDIR}"/README.Gentoo
-
- newinitd "${FILESDIR}"/kexec.init-2.0.4-r2 kexec
- newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
-
- insinto /etc
- doins "${FILESDIR}"/kexec.conf
-
- insinto /etc/kernel/postinst.d
- doins "${FILESDIR}"/90_kexec
-
- systemd_dounit "${FILESDIR}"/kexec.service
-}
-
-pkg_postinst() {
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "For systemd support the new config file is"
- elog " /etc/kexec.conf"
- elog "Please adopt it to your needs as there is no autoconfig anymore"
- fi
-}
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.9.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.9.ebuild
deleted file mode 100644
index 3f19f710c71e..000000000000
--- a/sys-apps/kexec-tools/kexec-tools-2.0.9.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools-utils flag-o-matic linux-info systemd
-
-DESCRIPTION="Load another kernel from the currently executing Linux kernel"
-HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
-SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="booke lzma xen zlib"
-
-REQUIRED_USE="lzma? ( zlib )"
-
-DEPEND="
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~KEXEC"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
- "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
-)
-
-pkg_setup() {
- # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
- export ASFLAGS="${CCASFLAGS}"
- # to disable the -fPIE -pie in the hardened compiler
- if gcc-specs-pie ; then
- filter-flags -fPIE
- append-ldflags -nopie
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with booke)
- $(use_with lzma)
- $(use_with xen)
- $(use_with zlib)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- dodoc "${FILESDIR}"/README.Gentoo
-
- newinitd "${FILESDIR}"/kexec.init-2.0.4-r2 kexec
- newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
-
- insinto /etc
- doins "${FILESDIR}"/kexec.conf
-
- insinto /etc/kernel/postinst.d
- doins "${FILESDIR}"/90_kexec
-
- systemd_dounit "${FILESDIR}"/kexec.service
-}
-
-pkg_postinst() {
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "For systemd support the new config file is"
- elog " /etc/kexec.conf"
- elog "Please adopt it to your needs as there is no autoconfig anymore"
- fi
-}