summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-02 19:59:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-05 19:41:14 +0200
commit1ba5033b43472ce898f09c1c3cc054fe63f16ea0 (patch)
tree3ddbe63d357dfb61a0b00cdf59e8279c95b501e4
parentmedia-video/bino: add 2.2 (diff)
downloadgentoo-1ba5033b43472ce898f09c1c3cc054fe63f16ea0.tar.gz
gentoo-1ba5033b43472ce898f09c1c3cc054fe63f16ea0.tar.bz2
gentoo-1ba5033b43472ce898f09c1c3cc054fe63f16ea0.zip
media-video/imagination: add 3.6
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/707932 Closes: https://bugs.gentoo.org/885575 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--media-video/imagination/Manifest1
-rw-r--r--media-video/imagination/files/imagination-3.6-cflags.patch13
-rw-r--r--media-video/imagination/imagination-3.6.ebuild50
3 files changed, 64 insertions, 0 deletions
diff --git a/media-video/imagination/Manifest b/media-video/imagination/Manifest
index 740ba18c803f..f62bd64e44c3 100644
--- a/media-video/imagination/Manifest
+++ b/media-video/imagination/Manifest
@@ -1 +1,2 @@
DIST imagination-3.0.tar.gz 3327784 BLAKE2B 0322a68ab6c44e2b0d47bb89de6522249ca3507808ee3733f2f195923c4269591c2225271ef27b24c648cb6784a5c85bd6ca97142072e52641bdf7f80b9a9bc7 SHA512 0780ab572d8f4fc1e728befef79f974169438d723f67205e677c06cbe0dac06745868936e7d3eab5fc42728902f6b06eb5f9d7e836532c289df005ddab2104b8
+DIST imagination-3.6.tar.gz 3553509 BLAKE2B 39b345b073b123e68ab6a025b03ca23a38191cb2d2f5163d8b7722a8891d254f9fc7b54461c7d741ba6d2e7b25cb2029d9eec55e5115a5b8504dd85985c740aa SHA512 673651cf59baded805ba3993c6f9dff83f20ae9174d5f5e07b99d9d590eb817e6733cbc130a3d32502a84fa29bd78c4f1dd093c01aaedfef5f9425a59125865d
diff --git a/media-video/imagination/files/imagination-3.6-cflags.patch b/media-video/imagination/files/imagination-3.6-cflags.patch
new file mode 100644
index 000000000000..e1f2b1a4de61
--- /dev/null
+++ b/media-video/imagination/files/imagination-3.6-cflags.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 0be7802..d19c8ec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -50,7 +55,7 @@
+ if test "x${REVISION}" != "xr0"
+ then
+ # force debug mode for a SVN working copy
+- CFLAGS="-g -Wall"
++ CFLAGS+=" -Wall"
+ else
+ REVISION="-1"
+ fi
diff --git a/media-video/imagination/imagination-3.6.ebuild b/media-video/imagination/imagination-3.6.ebuild
new file mode 100644
index 000000000000..caefd7c2a3e8
--- /dev/null
+++ b/media-video/imagination/imagination-3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop xdg-utils
+
+DESCRIPTION="Simple DVD slideshow maker"
+HOMEPAGE="https://imagination.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/glib:2
+ media-sound/sox:=
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${PN}-3.0-fix-htmldir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon icons/48x48/${PN}.png
+
+ # only plugins
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}