summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmed Ammar <aammar@edge-techno.com>2008-11-04 12:27:54 +0200
committerAhmed Ammar <aammar@edge-techno.com>2008-11-04 12:27:54 +0200
commit8973bf01b19c7c0ec448a246c2a015dc88aa4f0a (patch)
tree4448f1ce99e437bcca093fa0d4cd2eba80250413 /x11-libs/libX11/files
parent[libxcb] Add missing version bump patch. (diff)
downloadx11-8973bf01b19c7c0ec448a246c2a015dc88aa4f0a.tar.gz
x11-8973bf01b19c7c0ec448a246c2a015dc88aa4f0a.tar.bz2
x11-8973bf01b19c7c0ec448a246c2a015dc88aa4f0a.zip
[libX11] Updated format-patches from handoff branch due to change in master.
Diffstat (limited to 'x11-libs/libX11/files')
-rw-r--r--x11-libs/libX11/files/xlib-0001-Use-XCB-s-new-socket-handoff-mechanism-rather-than-t.patch24
-rw-r--r--x11-libs/libX11/files/xlib-0002-Fix-XAllocID-race-hold-the-user-display-lock-until.patch8
-rw-r--r--x11-libs/libX11/files/xlib-0003-Permit-only-one-Xlib-thread-to-block-waiting-for-eve.patch8
-rw-r--r--x11-libs/libX11/files/xlib-0004-Ensure-that-_XReadEvents-always-leaves-an-event-in-t.patch8
4 files changed, 25 insertions, 23 deletions
diff --git a/x11-libs/libX11/files/xlib-0001-Use-XCB-s-new-socket-handoff-mechanism-rather-than-t.patch b/x11-libs/libX11/files/xlib-0001-Use-XCB-s-new-socket-handoff-mechanism-rather-than-t.patch
index e5004925..aba3429a 100644
--- a/x11-libs/libX11/files/xlib-0001-Use-XCB-s-new-socket-handoff-mechanism-rather-than-t.patch
+++ b/x11-libs/libX11/files/xlib-0001-Use-XCB-s-new-socket-handoff-mechanism-rather-than-t.patch
@@ -1,7 +1,7 @@
-From 50d5c8363da0cd10217d4f24e8561ed9a1e1881e Mon Sep 17 00:00:00 2001
-From: Josh Triplett <josh@freedesktop.org>
-Date: Sat, 15 Mar 2008 17:22:00 -0700
-Subject: [PATCH 1/4] Use XCB's new socket handoff mechanism rather than the old XCB Xlib lock.
+From 70fe1551f2faf239bbe22688bb7f65d9714baae2 Mon Sep 17 00:00:00 2001
+From: root <root@gentoo-dev.localdomain>
+Date: Tue, 4 Nov 2008 12:11:14 +0200
+Subject: [PATCH] Use XCB's new socket handoff mechanism rather than the old XCB Xlib lock.
Previously, Xlib/XCB used XCB's Xlib lock to prevent XCB from sending
requests between calls to Xlib's LockDisplay and UnlockDisplay macros.
@@ -47,26 +47,28 @@ the locks reduces implementation complexity and should not impact applications.
Commit by Jamey Sharp and Josh Triplett.
XCB's handoff mechanism inspired by Keith Packard.
+
+Conflicts:
+
+ configure.ac
---
- configure.ac | 4 +-
+ configure.ac | 2 +
src/Makefile.am | 1 -
src/OpenDis.c | 27 +++----
src/Xxcbint.h | 27 +-----
src/xcb_io.c | 194 +++++++++++++++++++++++++++++-----------------
src/xcb_lock.c | 235 -------------------------------------------------------
- 6 files changed, 140 insertions(+), 348 deletions(-)
+ 6 files changed, 140 insertions(+), 346 deletions(-)
delete mode 100644 src/xcb_lock.c
diff --git a/configure.ac b/configure.ac
-index 5febfb3..6141fa4 100644
+index 73bf00f..f8d0001 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -52,8 +52,8 @@ no)
+@@ -53,6 +53,8 @@ no)
AC_DEFINE(USE_XCB, 0, [Use XCB for low-level protocol implementation])
;;
*)
-- X11_REQUIRES="xcb-xlib >= 1.1.90"
-- X11_EXTRA_DEPS="xcb-xlib"
+ X11_REQUIRES="xcb >= 1.2"
+ X11_EXTRA_DEPS="xcb >= 1.2"
xdmauth="no" # XCB handles all auth
@@ -770,5 +772,5 @@ index 71b2383..0000000
- dpy->bufptr = dpy->buffer;
-}
--
-1.6.0.2.307.gc427.dirty
+1.6.0.3
diff --git a/x11-libs/libX11/files/xlib-0002-Fix-XAllocID-race-hold-the-user-display-lock-until.patch b/x11-libs/libX11/files/xlib-0002-Fix-XAllocID-race-hold-the-user-display-lock-until.patch
index 8d094d35..caaa6f64 100644
--- a/x11-libs/libX11/files/xlib-0002-Fix-XAllocID-race-hold-the-user-display-lock-until.patch
+++ b/x11-libs/libX11/files/xlib-0002-Fix-XAllocID-race-hold-the-user-display-lock-until.patch
@@ -1,7 +1,7 @@
-From d4e77ee5023cda7cb04afdce9be81eaf72785c2a Mon Sep 17 00:00:00 2001
+From e7259f73437bd8aadc7370c610e2b63b9a82a6aa Mon Sep 17 00:00:00 2001
From: Jamey Sharp <jamey@minilop.net>
-Date: Sun, 23 Mar 2008 16:33:27 -0700
-Subject: [PATCH 2/4] Fix XAllocID race: hold the user display lock until we have a new XID.
+Date: Sun, 23 Mar 2008 16:33:50 -0700
+Subject: [PATCH] Fix XAllocID race: hold the user display lock until we have a new XID.
Xlib built --without-xcb is also vulnerable to this race, and a similar
fix might work there too.
@@ -43,5 +43,5 @@ index 830ddb9..d0abf4c 100644
if(!(dpy->flags & XlibDisplayPrivSync))
{
--
-1.6.0.2.307.gc427.dirty
+1.6.0.3
diff --git a/x11-libs/libX11/files/xlib-0003-Permit-only-one-Xlib-thread-to-block-waiting-for-eve.patch b/x11-libs/libX11/files/xlib-0003-Permit-only-one-Xlib-thread-to-block-waiting-for-eve.patch
index 5762f30f..0b8fe76f 100644
--- a/x11-libs/libX11/files/xlib-0003-Permit-only-one-Xlib-thread-to-block-waiting-for-eve.patch
+++ b/x11-libs/libX11/files/xlib-0003-Permit-only-one-Xlib-thread-to-block-waiting-for-eve.patch
@@ -1,7 +1,7 @@
-From 1cfce69bf65d9631a72f8b20d637bf158c0afd20 Mon Sep 17 00:00:00 2001
+From d179d72a72ac42585a4a89207bb02b30e44707ab Mon Sep 17 00:00:00 2001
From: Keith Packard <keithp@keithp.com>
-Date: Sat, 11 Oct 2008 21:10:00 -0700
-Subject: [PATCH 3/4] Permit only one Xlib thread to block waiting for events
+Date: Sat, 11 Oct 2008 21:10:23 -0700
+Subject: [PATCH] Permit only one Xlib thread to block waiting for events
As Xlib queues events internally, we must prevent multiple Xlib threads from
entering XCB to wait for an event in case the queued event is to be
@@ -99,5 +99,5 @@ index d0abf4c..fc8e53f 100644
int _XEventsQueued(Display *dpy, int mode)
--
-1.6.0.2.307.gc427.dirty
+1.6.0.3
diff --git a/x11-libs/libX11/files/xlib-0004-Ensure-that-_XReadEvents-always-leaves-an-event-in-t.patch b/x11-libs/libX11/files/xlib-0004-Ensure-that-_XReadEvents-always-leaves-an-event-in-t.patch
index 3087efcb..b1256ead 100644
--- a/x11-libs/libX11/files/xlib-0004-Ensure-that-_XReadEvents-always-leaves-an-event-in-t.patch
+++ b/x11-libs/libX11/files/xlib-0004-Ensure-that-_XReadEvents-always-leaves-an-event-in-t.patch
@@ -1,7 +1,7 @@
-From bbeafc850181cc0bf9724c71f1aa0015acdb7480 Mon Sep 17 00:00:00 2001
+From e1ff172a05373656b42d502a0464924cad1b3a90 Mon Sep 17 00:00:00 2001
From: Keith Packard <keithp@keithp.com>
-Date: Sat, 11 Oct 2008 21:43:58 -0700
-Subject: [PATCH 4/4] Ensure that _XReadEvents always leaves an event in the queue on return
+Date: Sat, 11 Oct 2008 21:44:21 -0700
+Subject: [PATCH] Ensure that _XReadEvents always leaves an event in the queue on return
XNextEvent assumes that the event queue will be non-empty on return from
_XReadEvents, but with multiple event readers running, the previous change
@@ -29,5 +29,5 @@ index fc8e53f..2256a3f 100644
/*
--
-1.6.0.2.307.gc427.dirty
+1.6.0.3