summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2020-06-28 12:49:32 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-15 21:18:00 -0500
commit2c59152249ccc83c4e200cc57b177a44331139dd (patch)
tree841a6cae0eea6831af42db5d13ef075b7da2e1f0
parentapp-benchmarks/glmark2: add patch to fix compile (diff)
downloadx11-2c59152249ccc83c4e200cc57b177a44331139dd.tar.gz
x11-2c59152249ccc83c4e200cc57b177a44331139dd.tar.bz2
x11-2c59152249ccc83c4e200cc57b177a44331139dd.zip
app-benchmarks/glmark2: update to 2020.04
Satisfy some trivial repoman warnings as well. Closes: https://github.com/gentoo/x11/pull/3 Signed-off-by: Signed-off-by: Marty E. Plummer <hanetzer@startmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-benchmarks/glmark2/Manifest1
-rw-r--r--app-benchmarks/glmark2/files/glmark2-2020.04-Build-Fix-Python-3-incompatibility.patch25
-rw-r--r--app-benchmarks/glmark2/glmark2-2012.12_p285.ebuild5
-rw-r--r--app-benchmarks/glmark2/glmark2-2014.03.ebuild5
-rw-r--r--app-benchmarks/glmark2/glmark2-2020.04.ebuild66
-rw-r--r--app-benchmarks/glmark2/metadata.xml24
6 files changed, 109 insertions, 17 deletions
diff --git a/app-benchmarks/glmark2/Manifest b/app-benchmarks/glmark2/Manifest
index 2cd363e7..818bfe97 100644
--- a/app-benchmarks/glmark2/Manifest
+++ b/app-benchmarks/glmark2/Manifest
@@ -1,2 +1,3 @@
DIST glmark2-2012.12_p285.tar.gz 7779498 SHA256 85f014a28cf26b67cc5225b0e6e4ce9c611741c3acf7ac9909fb763a285482f3 SHA512 3efc6000de05b39b28b8fcde564dfc22d7fb2e8469998e84284e88d60865a4175548fbfa9aac8389a59154c4e6fc3ec9c19a99aedd52ad3b18c5962f930a51d2 WHIRLPOOL 7c392631b6e1aa13e65a0bd076624054bbab5727a739202d39eb2a3ad4fbd9a13051509fe6cf96d8a0492e5c1a639b5b9876693e34dea91fda93487068915d4d
DIST glmark2-2014.03.tar.gz 7801401 SHA256 bded41aaf918ce062d9b81e42cc5be943e6a80bc4ff9d046983b96102c3df6b5 SHA512 fe2781f56083ed6fcdecd70210cbe55609b679c447cf8634b0ab5a1c2dd8e4ca72a7b40fe260bb6d8b435aa21571283bfc659279d008ba5dea4df24bfbdca542 WHIRLPOOL 71f8c184907adbc5cb9059571bd03001b205d804e94a0de4479bcc97595adfe3c08bd9c6bebff74c6a0fce3854e176202db029eb17db4d453fbdd86df6b8e8e6
+DIST glmark2-2020.04.tar.gz 9364467 SHA256 0fa7723111c928a73c04d4fa4adfc15a9dea6d335fe189f59c74ae5af26f99a2 SHA512 68d72403ab5c6b4562faf43ae94159e4b8dcb697f62ea9dc3eac5634a3e22b19e14e215a081ae2a39e5db77e6f0f40d5ceb0281962600526d08121a197105a80 WHIRLPOOL 786bd372f6081b6c653489012267581a77d625b4e8b353ad7fcc925ec680f0bbb7685ae89f2c9b5bb3d67c330998d22b13ab4415122cdc401ad6c1eb65d1b92c
diff --git a/app-benchmarks/glmark2/files/glmark2-2020.04-Build-Fix-Python-3-incompatibility.patch b/app-benchmarks/glmark2/files/glmark2-2020.04-Build-Fix-Python-3-incompatibility.patch
new file mode 100644
index 00000000..ca13bb8b
--- /dev/null
+++ b/app-benchmarks/glmark2/files/glmark2-2020.04-Build-Fix-Python-3-incompatibility.patch
@@ -0,0 +1,25 @@
+From 06e4728ba7312efa0fd595e30745e60ce88f1a4f Mon Sep 17 00:00:00 2001
+From: Marvin Schmidt <marv@exherbo.org>
+Date: Sun, 3 May 2020 18:20:05 +0200
+Subject: [PATCH] Build: Fix Python 3 incompatibility
+
+---
+ wscript | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wscript b/wscript
+index aefde70..e09fa78 100644
+--- a/wscript
++++ b/wscript
+@@ -20,7 +20,7 @@ FLAVORS = {
+ 'x11-gl' : 'glmark2',
+ 'x11-glesv2' : 'glmark2-es2',
+ }
+-FLAVORS_STR = ", ".join(sorted(FLAVORS.keys() + ['all-linux', 'all-win32']))
++FLAVORS_STR = ", ".join(sorted(list(FLAVORS) + ['all-linux', 'all-win32']))
+
+ def linux_flavors():
+ return [f for f in FLAVORS.keys() if not f.startswith('win32')]
+--
+2.27.0
+
diff --git a/app-benchmarks/glmark2/glmark2-2012.12_p285.ebuild b/app-benchmarks/glmark2/glmark2-2012.12_p285.ebuild
index bfa50a43..ce4a9ced 100644
--- a/app-benchmarks/glmark2/glmark2-2012.12_p285.ebuild
+++ b/app-benchmarks/glmark2/glmark2-2012.12_p285.ebuild
@@ -1,6 +1,5 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
@@ -15,7 +14,7 @@ SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/${REV} -
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~arm ~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="drm +gles2 opengl wayland X"
RDEPEND="media-libs/libpng
diff --git a/app-benchmarks/glmark2/glmark2-2014.03.ebuild b/app-benchmarks/glmark2/glmark2-2014.03.ebuild
index 4d47a987..19c7b21c 100644
--- a/app-benchmarks/glmark2/glmark2-2014.03.ebuild
+++ b/app-benchmarks/glmark2/glmark2-2014.03.ebuild
@@ -1,6 +1,5 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
@@ -15,7 +14,7 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~arm ~amd64 ~x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="drm gles2 +opengl wayland X"
RDEPEND="media-libs/libpng
diff --git a/app-benchmarks/glmark2/glmark2-2020.04.ebuild b/app-benchmarks/glmark2/glmark2-2020.04.ebuild
new file mode 100644
index 00000000..230109a4
--- /dev/null
+++ b/app-benchmarks/glmark2/glmark2-2020.04.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit waf-utils python-single-r1
+
+REV=${PV#*_p}
+
+DESCRIPTION="Opengl test suite"
+HOMEPAGE="https://launchpad.net/glmark2"
+SRC_URI="https://github.com/glmark2/glmark2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="drm gles2 +opengl wayland X"
+
+RDEPEND="media-libs/libpng
+ media-libs/mesa[gles2?]
+ X? ( x11-libs/libX11 )
+ wayland? ( >=dev-libs/wayland-1.2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( opengl gles2 )
+ || ( drm wayland X )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-2020.04-Build-Fix-Python-3-incompatibility.patch
+)
+
+src_prepare() {
+ default
+ rm -rf "${S}/src/libpng"
+}
+
+src_configure() {
+ : ${WAF_BINARY:="${S}/waf"}
+
+ local myconf
+
+ if use X; then
+ use opengl && myconf+="x11-gl"
+ use gles2 && myconf+=",x11-glesv2"
+ fi
+
+ if use drm; then
+ use opengl && myconf+=",drm-gl"
+ use gles2 && myconf+=",drm-glesv2"
+ fi
+
+ if use wayland; then
+ use opengl && myconf+=",wayland-gl"
+ use gles2 && myconf+=",wayland-glesv2"
+
+ fi
+ myconf=${myconf#,}
+
+ # it does not know --libdir specification, dandy huh
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ --prefix=/usr \
+ --with-flavors ${myconf} \
+ configure || die "configure failed"
+}
diff --git a/app-benchmarks/glmark2/metadata.xml b/app-benchmarks/glmark2/metadata.xml
index 7b1a8138..dcf2721b 100644
--- a/app-benchmarks/glmark2/metadata.xml
+++ b/app-benchmarks/glmark2/metadata.xml
@@ -1,16 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>x11</herd>
-<use>
- <flag name='drm'>Enable DRM backend support</flag>
- <flag name='gles2'>Enable GLES2 support</flag>
-</use>
-<upstream>
- <bugs-to>https://bugs.launchpad.net/glmark2/+filebug</bugs-to>
-</upstream>
-<longdescription>
-glmark2 is a benchmark for OpenGL (ES) 2.0. It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0.
-</longdescription>
+ <maintainer type="project">
+ <email>x11@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='drm'>Enable DRM backend support</flag>
+ <flag name='gles2'>Enable GLES2 support</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://bugs.launchpad.net/glmark2/+filebug</bugs-to>
+ </upstream>
+ <longdescription>
+ glmark2 is a benchmark for OpenGL (ES) 2.0. It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0.
+ </longdescription>
</pkgmetadata>