summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/pwlib/pwlib-1.9.2.ebuild')
-rw-r--r--dev-libs/pwlib/pwlib-1.9.2.ebuild53
1 files changed, 5 insertions, 48 deletions
diff --git a/dev-libs/pwlib/pwlib-1.9.2.ebuild b/dev-libs/pwlib/pwlib-1.9.2.ebuild
index 811a782..67518c2 100644
--- a/dev-libs/pwlib/pwlib-1.9.2.ebuild
+++ b/dev-libs/pwlib/pwlib-1.9.2.ebuild
@@ -4,7 +4,7 @@
inherit eutils flag-o-matic multilib
-IUSE="alsa esd ieee1394 ipv6 oss sdl ssl v4l2"
+IUSE="alsa ieee1394 ipv6 oss sdl ssl v4l v4l2"
DESCRIPTION="Portable Multiplatform Class Libraries used by several VoIP applications"
HOMEPAGE="http://www.voxgratia.org/"
@@ -24,8 +24,7 @@ RDEPEND="
sys-libs/libavc1394
sys-libs/libraw1394
<media-libs/libdc1394-1.9.99
- !>=media-libs/libdc1394-2.0.0_pre1 )
- esd? ( media-sound/esound )"
+ !>=media-libs/libdc1394-2.0.0_pre1 )"
DEPEND="${RDEPEND}
>=sys-devel/bison-1.28
@@ -43,10 +42,6 @@ src_unpack() {
-e "s:-Os::" \
make/unix.mak
- # newer esound package doesn't install libesd.a anymore,
- # use dynamic library instead (fixes #100432)
- epatch ${FILESDIR}/pwlib-1.6.3-dyn-esd.patch
-
# don't break make install if there are no plugins to install
epatch ${FILESDIR}/pwlib-1.8.7-instplugins.diff
@@ -65,37 +60,17 @@ src_compile() {
# may cause ICE (bug #70638)
filter-flags -fstack-protector
-# if use ssl; then
-# export OPENSSLFLAG=1
-# export OPENSSLDIR="/usr"
-# export OPENSSLLIBS="-lssl -lcrypt"
-# fi
-
- ## gnomemeeting-1.00 requires pwlib to be built w/ IPV6 support
- ## (even if itself is built without...)
- #use ipv6 \
- # && myconf="${myconf} --enable-ipv6" \
- # || myconf="${myconf} --disable-ipv6"
-# myconf="--enable-ipv6"
-
- if use esd; then
- # fixes bug #45059
- export ESDDIR=/usr
-
- # ESD includes are in /usr/include?
- # remove include path, bad things may happen if we leave it in there
- sed -i -e "s:-I\$(ESDDIR)/include::" \
- ${S}/make/unix.mak
- fi
-
econf \
--enable-plugins \
$(use_enable v4l2) \
+ $(use_enable v4l) \
$(use_enable ieee1394 dc) \
$(use_enable ieee1394 avc) \
$(use_enable oss) \
$(use_enable alsa) \
$(use_enable ipv6) \
+ $(use_enable sdl) \
+ $(use_enable ssl openssl) \
${myconf} || die "configure failed"
# Horrible hack to strip out -L/usr/lib to allow upgrades
@@ -113,18 +88,6 @@ src_compile() {
emake -j1 opt || die "make failed"
}
-#pkg_preinst() {
-# # remove {lib,include} directories in /usr/share/pwlib
-# # they are getting replaced by symlinks in src_install
-#
-# if [[ -d ${ROOT}usr/share/pwlib/include ]]; then
-# rm -rf ${ROOT}usr/share/pwlib/include
-# fi
-# if [[ -d ${ROOT}usr/share/pwlib/$(get_libdir) ]]; then
-# rm -rf ${ROOT}usr/share/pwlib/$(get_libdir)
-# fi
-#}
-
src_install() {
local libdir libname
@@ -159,12 +122,6 @@ src_install() {
rm ${D}/usr/${libdir}/libpt.so
dosym ${libname} /usr/${libdir}/libpt.so
- # strip ${S} stuff
-# sed -i -e "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" \
-# ${D}/usr/bin/ptlib-config \
-# ${D}/usr/share/pwlib/make/ptlib-config \
-# ${D}/usr/share/pwlib/make/ptbuildopts.mak
-
# fix makefiles to use headers from /usr/include and libs from /usr/lib
# instead of /usr/share/pwlib
# Note: change to /usr/include/pwlib-${PV} (or whereever includes will be)