summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-04 14:31:19 -0400
committerMike Frysinger <vapier@gentoo.org>2015-04-04 14:31:19 -0400
commitad085afa78ad93f9d83a0b0b3249510438270d0a (patch)
treea1abd146b2867f73bfeb2fa8b3c1325c4743b90e
parentgdb: drop old lzma-utils references (diff)
downloadtoolchain-ad085afa78ad93f9d83a0b0b3249510438270d0a.tar.gz
toolchain-ad085afa78ad93f9d83a0b0b3249510438270d0a.tar.bz2
toolchain-ad085afa78ad93f9d83a0b0b3249510438270d0a.zip
gdb: update to EAPI=5 and depend on readline SLOT=0
-rw-r--r--sys-devel/gdb/gdb-7.3.50.20111129.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.3.50.20111206.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.3.50.20111213.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.4.50.20120703.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.4.50.20120710.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.4.50.20120717.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.5.50.20130226.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.5.50.20130305.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.5.50.20130312.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.6.50.20131224.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.6.50.20131231.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.6.50.20140107.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.7.50.20140527.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.7.50.20140603.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.7.50.20140610.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.8.50.20141209.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.8.50.20141216.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.8.50.20141223.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.8.50.20141231.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.8.50.20150106.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.8.50.20150113.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.9.50.20150310.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.9.50.20150317.ebuild4
-rw-r--r--sys-devel/gdb/gdb-7.9.50.20150324.ebuild4
-rw-r--r--sys-devel/gdb/metadata.xml10
25 files changed, 58 insertions, 48 deletions
diff --git a/sys-devel/gdb/gdb-7.3.50.20111129.ebuild b/sys-devel/gdb/gdb-7.3.50.20111129.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.3.50.20111129.ebuild
+++ b/sys-devel/gdb/gdb-7.3.50.20111129.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.3.50.20111206.ebuild b/sys-devel/gdb/gdb-7.3.50.20111206.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.3.50.20111206.ebuild
+++ b/sys-devel/gdb/gdb-7.3.50.20111206.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.3.50.20111213.ebuild b/sys-devel/gdb/gdb-7.3.50.20111213.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.3.50.20111213.ebuild
+++ b/sys-devel/gdb/gdb-7.3.50.20111213.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.4.50.20120703.ebuild b/sys-devel/gdb/gdb-7.4.50.20120703.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.4.50.20120703.ebuild
+++ b/sys-devel/gdb/gdb-7.4.50.20120703.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.4.50.20120710.ebuild b/sys-devel/gdb/gdb-7.4.50.20120710.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.4.50.20120710.ebuild
+++ b/sys-devel/gdb/gdb-7.4.50.20120710.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.4.50.20120717.ebuild b/sys-devel/gdb/gdb-7.4.50.20120717.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.4.50.20120717.ebuild
+++ b/sys-devel/gdb/gdb-7.4.50.20120717.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.5.50.20130226.ebuild b/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
+++ b/sys-devel/gdb/gdb-7.5.50.20130226.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.5.50.20130305.ebuild b/sys-devel/gdb/gdb-7.5.50.20130305.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.5.50.20130305.ebuild
+++ b/sys-devel/gdb/gdb-7.5.50.20130305.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.5.50.20130312.ebuild b/sys-devel/gdb/gdb-7.5.50.20130312.ebuild
index c29471b..2844e14 100644
--- a/sys-devel/gdb/gdb-7.5.50.20130312.ebuild
+++ b/sys-devel/gdb/gdb-7.5.50.20130312.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit flag-o-matic eutils python-single-r1
@@ -57,7 +57,7 @@ IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
diff --git a/sys-devel/gdb/gdb-7.6.50.20131224.ebuild b/sys-devel/gdb/gdb-7.6.50.20131224.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.6.50.20131224.ebuild
+++ b/sys-devel/gdb/gdb-7.6.50.20131224.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.6.50.20131231.ebuild b/sys-devel/gdb/gdb-7.6.50.20131231.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.6.50.20131231.ebuild
+++ b/sys-devel/gdb/gdb-7.6.50.20131231.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.6.50.20140107.ebuild b/sys-devel/gdb/gdb-7.6.50.20140107.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.6.50.20140107.ebuild
+++ b/sys-devel/gdb/gdb-7.6.50.20140107.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.7.50.20140527.ebuild b/sys-devel/gdb/gdb-7.7.50.20140527.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.7.50.20140527.ebuild
+++ b/sys-devel/gdb/gdb-7.7.50.20140527.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.7.50.20140603.ebuild b/sys-devel/gdb/gdb-7.7.50.20140603.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.7.50.20140603.ebuild
+++ b/sys-devel/gdb/gdb-7.7.50.20140603.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.7.50.20140610.ebuild b/sys-devel/gdb/gdb-7.7.50.20140610.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.7.50.20140610.ebuild
+++ b/sys-devel/gdb/gdb-7.7.50.20140610.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.8.50.20141209.ebuild b/sys-devel/gdb/gdb-7.8.50.20141209.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.8.50.20141209.ebuild
+++ b/sys-devel/gdb/gdb-7.8.50.20141209.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.8.50.20141216.ebuild b/sys-devel/gdb/gdb-7.8.50.20141216.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.8.50.20141216.ebuild
+++ b/sys-devel/gdb/gdb-7.8.50.20141216.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.8.50.20141223.ebuild b/sys-devel/gdb/gdb-7.8.50.20141223.ebuild
index d3cad2c..c038260 100644
--- a/sys-devel/gdb/gdb-7.8.50.20141223.ebuild
+++ b/sys-devel/gdb/gdb-7.8.50.20141223.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit flag-o-matic eutils python-single-r1
@@ -58,7 +58,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.8.50.20141231.ebuild b/sys-devel/gdb/gdb-7.8.50.20141231.ebuild
index d1e1fcd..50f445c 100644
--- a/sys-devel/gdb/gdb-7.8.50.20141231.ebuild
+++ b/sys-devel/gdb/gdb-7.8.50.20141231.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.32 2015/02/17 10:44:28 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit flag-o-matic eutils python-single-r1
@@ -62,7 +62,7 @@ REQUIRED_USE="
RDEPEND="server? ( !dev-util/gdbserver )
client? (
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.8.50.20150106.ebuild b/sys-devel/gdb/gdb-7.8.50.20150106.ebuild
index d1e1fcd..50f445c 100644
--- a/sys-devel/gdb/gdb-7.8.50.20150106.ebuild
+++ b/sys-devel/gdb/gdb-7.8.50.20150106.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.32 2015/02/17 10:44:28 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit flag-o-matic eutils python-single-r1
@@ -62,7 +62,7 @@ REQUIRED_USE="
RDEPEND="server? ( !dev-util/gdbserver )
client? (
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.8.50.20150113.ebuild b/sys-devel/gdb/gdb-7.8.50.20150113.ebuild
index d1e1fcd..50f445c 100644
--- a/sys-devel/gdb/gdb-7.8.50.20150113.ebuild
+++ b/sys-devel/gdb/gdb-7.8.50.20150113.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.32 2015/02/17 10:44:28 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit flag-o-matic eutils python-single-r1
@@ -62,7 +62,7 @@ REQUIRED_USE="
RDEPEND="server? ( !dev-util/gdbserver )
client? (
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.9.50.20150310.ebuild b/sys-devel/gdb/gdb-7.9.50.20150310.ebuild
index d1e1fcd..50f445c 100644
--- a/sys-devel/gdb/gdb-7.9.50.20150310.ebuild
+++ b/sys-devel/gdb/gdb-7.9.50.20150310.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.32 2015/02/17 10:44:28 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit flag-o-matic eutils python-single-r1
@@ -62,7 +62,7 @@ REQUIRED_USE="
RDEPEND="server? ( !dev-util/gdbserver )
client? (
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.9.50.20150317.ebuild b/sys-devel/gdb/gdb-7.9.50.20150317.ebuild
index d1e1fcd..50f445c 100644
--- a/sys-devel/gdb/gdb-7.9.50.20150317.ebuild
+++ b/sys-devel/gdb/gdb-7.9.50.20150317.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.32 2015/02/17 10:44:28 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit flag-o-matic eutils python-single-r1
@@ -62,7 +62,7 @@ REQUIRED_USE="
RDEPEND="server? ( !dev-util/gdbserver )
client? (
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/gdb-7.9.50.20150324.ebuild b/sys-devel/gdb/gdb-7.9.50.20150324.ebuild
index d1e1fcd..50f445c 100644
--- a/sys-devel/gdb/gdb-7.9.50.20150324.ebuild
+++ b/sys-devel/gdb/gdb-7.9.50.20150324.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.32 2015/02/17 10:44:28 vapier Exp $
-EAPI="4"
+EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit flag-o-matic eutils python-single-r1
@@ -62,7 +62,7 @@ REQUIRED_USE="
RDEPEND="server? ( !dev-util/gdbserver )
client? (
>=sys-libs/ncurses-5.2-r2
- sys-libs/readline
+ sys-libs/readline:0=
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
diff --git a/sys-devel/gdb/metadata.xml b/sys-devel/gdb/metadata.xml
index fb4199e..688bfcb 100644
--- a/sys-devel/gdb/metadata.xml
+++ b/sys-devel/gdb/metadata.xml
@@ -2,4 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>toolchain</herd>
+<use>
+ <flag name='client'>Install the main "gdb" program (most people want this)</flag>
+ <flag name='lzma'>Support lzma compression in ELF debug info</flag>
+ <flag name='multitarget'>Support all known targets in one gdb binary</flag>
+ <flag name='python'>Enable support for the new internal scripting language, as well as extended pretty printers</flag>
+ <flag name='server'>Install the "gdbserver" program (useful for embedded/remote targets)</flag>
+</use>
+<upstream>
+ <remote-id type="cpe">cpe:/a:gnu:gdb</remote-id>
+</upstream>
</pkgmetadata>