summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-31 11:49:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-31 11:49:14 +0000
commit6001620c5ec9d6e937aebf4b756a7da808a83165 (patch)
tree746e6fa6ea32ea7750b69eab45e2b4e769efefd6 /net-misc
parentnet-misc/sambascanner: Migrate to EAPI2 in order to replace deprecated built_... (diff)
downloadsunrise-6001620c5ec9d6e937aebf4b756a7da808a83165.tar.gz
sunrise-6001620c5ec9d6e937aebf4b756a7da808a83165.tar.bz2
sunrise-6001620c5ec9d6e937aebf4b756a7da808a83165.zip
net-misc/ganyremote: Migrate to EAPI2 in order to drop deprecated built_with_use calls
svn path=/sunrise/; revision=9943
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ganyremote/ChangeLog5
-rw-r--r--net-misc/ganyremote/Manifest4
-rw-r--r--net-misc/ganyremote/ganyremote-5.8.ebuild15
3 files changed, 11 insertions, 13 deletions
diff --git a/net-misc/ganyremote/ChangeLog b/net-misc/ganyremote/ChangeLog
index 3e494b3d1..1ea677d4d 100644
--- a/net-misc/ganyremote/ChangeLog
+++ b/net-misc/ganyremote/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for net-misc/ganyremote
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 31 Jan 2010; Markos Chandras <hwoarang@gentoo.org> ganyremote-5.8.ebuild:
+ Migrate to EAPI2 in order to drop deprecated built_with_use calls
+
31 Mar 2009; Markos Chandras <hwoarang@gentoo.org> -ganyremote-5.7.ebuild,
+ganyremote-5.8.ebuild:
Version bump, remove old
diff --git a/net-misc/ganyremote/Manifest b/net-misc/ganyremote/Manifest
index 240122010..22f551a1a 100644
--- a/net-misc/ganyremote/Manifest
+++ b/net-misc/ganyremote/Manifest
@@ -1,4 +1,4 @@
DIST ganyremote-5.8.tar.gz 268928 RMD160 d5529438a31be4b317962f1ee0bd6f9535517028 SHA1 b6c2dc81513cc6cab7dd805e9b800184887ab9d6 SHA256 29a6f54c1c1cba1fdbdd2e92aa11b2d77267b0c766802f9ecf088b5ce0b74ba9
-EBUILD ganyremote-5.8.ebuild 838 RMD160 6e006c4c0db5f71cf1208acaf77fd23d67ca1bfa SHA1 92f00e2dd644b4939ec98e470f5a2e9c571feb30 SHA256 8bef17241a77a3d81dc72530e4fefb7e696f8578dedb176256a080f50c5457bb
-MISC ChangeLog 1159 RMD160 98043810afb57960f10b586a74afc1b708bcd05d SHA1 370b10af3cdca2f011ff5cb7d0fc3da6e90e5ba3 SHA256 04ae6ecad593827d157915fe70a0bff555a23773ebeecfa63d8d19590a6d3529
+EBUILD ganyremote-5.8.ebuild 657 RMD160 efeb76f282637dea9d3337169b29328400a834b8 SHA1 c91383582d41ca489e4e21acba3e254400c13ac6 SHA256 4706f59cba480d141a408c759e25eff92346f688bdbf0871d774dce7930753a0
+MISC ChangeLog 1304 RMD160 437deb87085b3851199a23bfa1c041e462af1400 SHA1 74edcb8911ce663d0d1e5fdbb66aa1979383d6ba SHA256 8f8978f4a9536cbe4f75367787d6abcd4fe16e38f8bad8ba5f4110d5789a20d4
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-misc/ganyremote/ganyremote-5.8.ebuild b/net-misc/ganyremote/ganyremote-5.8.ebuild
index f632c7d54..3c46da99b 100644
--- a/net-misc/ganyremote/ganyremote-5.8.ebuild
+++ b/net-misc/ganyremote/ganyremote-5.8.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit eutils
DESCRIPTION="Gnome frontend to Anyremote"
@@ -11,9 +13,9 @@ SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="bluetooth"
-DEPEND=" net-misc/anyremote
+DEPEND=" net-misc/anyremote[bluetooth=]
dev-python/pygtk
dev-python/pybluez "
RDEPEND="${DEPEND}"
@@ -23,10 +25,3 @@ src_install() {
make_desktop_entry ${PN} ${PN} ${PN}.png "Network;RemoteAccess"
dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
}
-
-pkg_postinst() {
- if ! built_with_use net-misc/anyremote bluetooth ; then
- ewarn "If you want to use bluetooth with ganyremote, you need to "
- ewarn "compile net-misc/anyremote with bluetooth use flag."
- fi
-}