summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-04-16 23:46:25 +0300
committerJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-04-16 23:46:36 +0300
commitbbe7a989a180c63f3d978ae6eb709c3d8a6afbbe (patch)
tree2089fc5b74cda8aff6313297c7a81346f63bba06 /dev-cpp/mpfrc++/mpfrc++-20120116.ebuild
parentReverse commit order for git diff in review script. (diff)
downloadsunrise-reviewed-bbe7a989a180c63f3d978ae6eb709c3d8a6afbbe.tar.gz
sunrise-reviewed-bbe7a989a180c63f3d978ae6eb709c3d8a6afbbe.tar.bz2
sunrise-reviewed-bbe7a989a180c63f3d978ae6eb709c3d8a6afbbe.zip
dev-cpp/mpfrc++: New ebuild for bug #412249 thanks to hasufell and floppym
Diffstat (limited to 'dev-cpp/mpfrc++/mpfrc++-20120116.ebuild')
-rw-r--r--dev-cpp/mpfrc++/mpfrc++-20120116.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/mpfrc++/mpfrc++-20120116.ebuild b/dev-cpp/mpfrc++/mpfrc++-20120116.ebuild
new file mode 100644
index 000000000..1e1d619bb
--- /dev/null
+++ b/dev-cpp/mpfrc++/mpfrc++-20120116.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit multilib toolchain-funcs vcs-snapshot
+
+DESCRIPTION="High-performance C++ interface for MPFR library"
+HOMEPAGE="http://www.holoborodko.com/pavel/mpfr/"
+SRC_URI="https://bitbucket.org/advanpix/nika/get/88fa1ed2a7a5.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/mpfr"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp "${FILESDIR}/Makefile" Makefile || die
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dolib.so lib${PN}.so.${PV}
+ dosym lib${PN}.so.${PV} usr/$(get_libdir)/lib${PN}.so
+ insinto usr/include
+ doins dlmalloc.h mpreal.h
+}