aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-12-16 19:48:34 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-17 11:43:58 +0100
commit919adcf3380de65fd71af28bf9bbb1833309dd4b (patch)
tree05a1b46c7724fbc83c80ff1a540caaa10a2e1a0d /net-misc
parentsci-libs/xblas: fix IndirectInherits (diff)
downloadsci-919adcf3380de65fd71af28bf9bbb1833309dd4b.tar.gz
sci-919adcf3380de65fd71af28bf9bbb1833309dd4b.tar.bz2
sci-919adcf3380de65fd71af28bf9bbb1833309dd4b.zip
net-misc/cernbox-client: Bump to 2.9.2.6206.
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cernbox-client/Manifest1
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.9.2.6206.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index e83150294..c9d27b7c5 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -1,3 +1,4 @@
DIST cernbox-client-2.7.1-2596.src.rpm 15434250 BLAKE2B 3ef3fcc4010b3f292aee9b6bba7b5f9a72e4fbca1236e1e85e6523cd4e38d980fe4542c5f019647a19040be64628159651630a61ee8894cb7bcf4b69d342ccd0 SHA512 e329b84fc7aa62068f934bf8a9f47432709094adc618274c1b8ddbf7331094cb71b6208d3a777150ee426141301e0279cb219d65b123335f2e198a9b87980e5d
DIST ownCloud-2.8.2.4246.tar.xz 15044652 BLAKE2B ee1ee412667266273a9a9722940559562c6c43213b013fe7c21328e04ac967afb16f460e6fa711f37d1d4ea7d0fc15fc398d835cf6a939f4c8dfd54cd4846fed SHA512 0ab2ef72191cc2d5c2621c97c09cb1d25472a30f511235a190465e246a8312f13a255011abb9690c481887f2f15094414c87ce594252eb8debcb39b9cbc8a178
DIST ownCloud-2.9.1.5500.tar.xz 5787048 BLAKE2B 6f7df0c1ca13e6074bbd75caaee838ddb822f9284a4f5cc95e1b2c1432adf2969e2413607bebc1542d4bc7790bd6e61edfba758d2205a23fbede6873b7e22316 SHA512 5c78cd0318b7cd35f32721cf364d6e807d32eb1f3651e7f22ff3f3c7737967193ad089062965b3dcee24c23c14cc0d7acdfc95094f4f90f8aaf718f45f22e18a
+DIST ownCloud-2.9.2.6206.tar.xz 5759996 BLAKE2B c328ea261a4fddecf93837dbcac01aab0971542d8dfb3f5b0a32a8432ca0e0904c3f4fc81c5c7811da8b3af64b58e929c055e7cec0649f00049e037372948eec SHA512 d075a11ee92aa9771c631a766feddfa1a70907d7d341b58043e1ba96ac52786a6a750b15c2f9b7a0992fe02a45586cc3445755dc9df4cd267e72f070d2222f0f
diff --git a/net-misc/cernbox-client/cernbox-client-2.9.2.6206.ebuild b/net-misc/cernbox-client/cernbox-client-2.9.2.6206.ebuild
new file mode 100644
index 000000000..27080cd72
--- /dev/null
+++ b/net-misc/cernbox-client/cernbox-client-2.9.2.6206.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake rpm xdg
+
+DESCRIPTION="Synchronize files from CERNBox EOS with your computer"
+
+# Origin is classic owncloud-client, branded for CERN during compilation.
+ORIGIN_PN="ownCloud"
+BRANDED_P="cernbox"
+BRANDED_PV="2.7.1"
+BRANDED_REL="2596"
+HOMEPAGE="https://cernbox.cern.ch/"
+SRC_URI="https://download.owncloud.com/desktop/${ORIGIN_PN}/stable/${PV}/source/${ORIGIN_PN}-${PV}.tar.xz
+ https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
+ https://cern.ch/ofreyerm/gentoo/cernbox/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dolphin gnome-keyring nautilus test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-fs/inotify-tools
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )"
+
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${ORIGIN_PN}-${PV}
+
+PATCHES=( "${FILESDIR}"/cernbox-theme-2.9.1.patch )
+
+src_unpack() {
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm || die "failed to extract branding RPM"
+ mv ${PN%-*}-${BRANDED_PV}.${BRANDED_REL}/branding "${S}" || die "failed to extract branding"
+}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DBUILD_SHELL_INTEGRATION_DOLPHIN=$(usex dolphin)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}