aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-02 14:01:13 +0100
committerHorea Christian <chr@chymera.eu>2021-01-02 23:30:51 -0500
commit70f8a2925272cb3e252372debe35b6ef791535da (patch)
tree2d76bf05810553fc85eaae93c728becf20956032 /dev-python
parentdev-python/delegator: drop py3.6, keyword x86 (diff)
downloadsci-70f8a2925272cb3e252372debe35b6ef791535da.tar.gz
sci-70f8a2925272cb3e252372debe35b6ef791535da.tar.bz2
sci-70f8a2925272cb3e252372debe35b6ef791535da.zip
dev-python/num2words: version bump, fix tests
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/num2words/Manifest3
-rw-r--r--dev-python/num2words/num2words-0.5.10.ebuild (renamed from dev-python/num2words/num2words-0.5.9.ebuild)20
-rw-r--r--dev-python/num2words/num2words-0.5.6.ebuild26
3 files changed, 10 insertions, 39 deletions
diff --git a/dev-python/num2words/Manifest b/dev-python/num2words/Manifest
index fe1be4268..5a0bcf9bb 100644
--- a/dev-python/num2words/Manifest
+++ b/dev-python/num2words/Manifest
@@ -1,2 +1 @@
-DIST num2words-0.5.6.tar.gz 55475 BLAKE2B 954c314762cb63ecf229eee465a7a88688eec00b940a73f6a2fe843a55bee65ce4590a865e607ae665d2248158cb69f196e5e5d9e6d91867305496fe6192de33 SHA512 6f6d979f8352268ee139681b3fecb659e67ba885806801e2424700b6a002883f6326b85497438e721a476b92a145e6f61a61929ec6bd885309f555f86959b66e
-DIST num2words-0.5.9.tar.gz 106780 BLAKE2B 1a54bfac6ba1ec9580f945b8f0b59e88b9f095bf58a526db0ed2f7783f5a03a129399ea346df1bec4910387d466f1943b498b8dcd7cf659973a8cde1d5355fbd SHA512 004d02d7591294735098b707d5cde665b476ea2297dc9854a98fa3703238eab077957fe1edf3821a180b0d396f16e18f10d53a0417841220095236b73275fb41
+DIST num2words-0.5.10.tar.gz 114781 BLAKE2B 799df95e048ebc4a1868b1cbc7498301724d4e10c950e2202f04211653dbcca85cce30709434b28e9fef1a5c01ac0259d1046bcbecf84d24cef5528fdacae88b SHA512 16938cc3af36719975986b2d9caeb3853ca5a11fa7d982531420296f4c3730b096efb16d24d84a5260a2510914ab86436083dc9c63a372728cf745f3a1a5ba77
diff --git a/dev-python/num2words/num2words-0.5.9.ebuild b/dev-python/num2words/num2words-0.5.10.ebuild
index 4ce161c21..7e62a328d 100644
--- a/dev-python/num2words/num2words-0.5.9.ebuild
+++ b/dev-python/num2words/num2words-0.5.10.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Modules to convert numbers to words."
HOMEPAGE="https://github.com/savoirfairelinux/num2words"
-SRC_URI="https://github.com/savoirfairelinux/num2words/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
+KEYWORDS="~amd64 ~x86"
-DEPEND="
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]"
+
+BDEPEND="
test? ( dev-python/delegator[${PYTHON_USEDEP}] )
- "
-RDEPEND=""
+"
-python_test() {
- ${EPYTHON} setup.py test || die
-}
+distutils_enable_tests pytest
diff --git a/dev-python/num2words/num2words-0.5.6.ebuild b/dev-python/num2words/num2words-0.5.6.ebuild
deleted file mode 100644
index 1e541df7d..000000000
--- a/dev-python/num2words/num2words-0.5.6.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Modules to convert numbers to words."
-HOMEPAGE="https://github.com/savoirfairelinux/num2words"
-SRC_URI="https://github.com/savoirfairelinux/num2words/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- "
-RDEPEND=""
-
-python_test() {
- ${EPYTHON} setup.py test || die
-}