aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 11:23:15 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:10 +0200
commite0b44a7587c8bd5ad22f1fac28aaf7fe5043fc95 (patch)
tree78f2e3e0e979c2de6f43428c17673dc775d9bf49
parentdev-python/uhi: add 0.5.0 (diff)
downloadsci-e0b44a7587c8bd5ad22f1fac28aaf7fe5043fc95.tar.gz
sci-e0b44a7587c8bd5ad22f1fac28aaf7fe5043fc95.tar.bz2
sci-e0b44a7587c8bd5ad22f1fac28aaf7fe5043fc95.zip
dev-python/boost-histogram: add 1.5.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--dev-python/boost-histogram/Manifest1
-rw-r--r--dev-python/boost-histogram/boost-histogram-1.5.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/boost-histogram/Manifest b/dev-python/boost-histogram/Manifest
index 78bf6ae03..5f9267a4b 100644
--- a/dev-python/boost-histogram/Manifest
+++ b/dev-python/boost-histogram/Manifest
@@ -1 +1,2 @@
DIST boost_histogram-1.4.1.tar.gz 1337723 BLAKE2B 42087abfd34471f42b06571ab4e701e7fbc071a5b9f3133f6f80831a0fd01ef95f65cae7bdcc6892674a415fd9b48a20bb0ecd5fd294a4880a6f5e3922e60a09 SHA512 fda8085929677a1664030fd29beb01caf37b42413fe941c2760fed17325301c4bf6b8ec5fa3b0e128558a52dee3245ec3a3fc2f4ca145dd09dea0b88fcfa33d4
+DIST boost_histogram-1.5.0.tar.gz 1181192 BLAKE2B b25e20b9440849d9cd4837b762bcc7a9625e69fec60dbe4a975b0329678e0035d5d29d8ea5a7a35b1b78ee00b1c8941361774f0dcd069da04f67632b98af5783 SHA512 5c107f69514fbbad013e2e2a265537c55f4500b61bbb6a37cfb3a69fcf92d4cfba333ba27b43df444cf6120768d5a324822019dcccac58ce0ae127630f8bf999
diff --git a/dev-python/boost-histogram/boost-histogram-1.5.0.ebuild b/dev-python/boost-histogram/boost-histogram-1.5.0.ebuild
new file mode 100644
index 000000000..7bee5b066
--- /dev/null
+++ b/dev-python/boost-histogram/boost-histogram-1.5.0.ebuild
@@ -0,0 +1,43 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=scikit-build-core
+DISTUTILS_EXT=1
+inherit cmake distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the C++14 Boost::Histogram library"
+HOMEPAGE="https://github.com/scikit-hep/boost-histogram"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-python/pybind11-2.13.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ default
+ sed -i 's/\["pytest-benchmark"\]/[]/g' pyproject.toml || die
+ # https://github.com/scikit-build/scikit-build-core/issues/912
+ sed -i -e '/scikit-build-core/s:0\.10:0.8:' pyproject.toml || die
+}
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmark_1d.py
+ tests/test_benchmark_2d.py
+ tests/test_benchmark_category_axis.py
+ tests/test_pickle.py
+ tests/test_threaded_fill.py
+)