aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-07-16 09:57:43 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-18 13:30:33 +0200
commita164bf307ec935fd566a4342aa9b691dcb470964 (patch)
tree28ea619e769505dd681333661b5de879fc35d446
parentprofiles: mask sci-biology/BBmap (diff)
downloadsci-a164bf307ec935fd566a4342aa9b691dcb470964.tar.gz
sci-a164bf307ec935fd566a4342aa9b691dcb470964.tar.bz2
sci-a164bf307ec935fd566a4342aa9b691dcb470964.zip
sci-biology/bx-python: version bump 0.12.0, enable tests
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Closes: https://github.com/gentoo/sci/pull/1287 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-biology/bx-python/Manifest3
-rw-r--r--sci-biology/bx-python/bx-python-0.12.0.ebuild41
-rw-r--r--sci-biology/bx-python/bx-python-0.8.9.ebuild35
-rw-r--r--sci-biology/bx-python/bx-python-0.9.0.ebuild35
-rw-r--r--sci-biology/bx-python/bx-python-9999.ebuild35
-rw-r--r--sci-biology/bx-python/files/no-doctest.patch9
-rw-r--r--sci-biology/bx-python/metadata.xml4
7 files changed, 51 insertions, 111 deletions
diff --git a/sci-biology/bx-python/Manifest b/sci-biology/bx-python/Manifest
index 90147dff7..69572ef1e 100644
--- a/sci-biology/bx-python/Manifest
+++ b/sci-biology/bx-python/Manifest
@@ -1,2 +1 @@
-DIST bx-python-0.8.9.gh.tar.gz 1651514 BLAKE2B ee75d08aaae8102c2af5be0175c75200382e157abc0c0c723a67b55d5542ab2d4b6ccd4e256975b0a2d00b39b2249d73df0c6f4324b3a74757c3e18e2aeb6c1a SHA512 37863c92258dc06a12b566b02697502f68bbf7e4d9decd8fc63af10ee58b614dd0e7cff35e9977ba1ddf913f176c49e7969728d8e64a9f78ac7100da4a3d70ea
-DIST bx-python-0.9.0.gh.tar.gz 1667445 BLAKE2B 0814792a2af8bfb7af5ef5fe1ddc184ed14a68df060a8286f4eba334388497363dc002f6c0de72836b5654452fe28f4cef67cd31b765a4a121c84f3af0634ea0 SHA512 955f396614d8e6d19a74e94a6612f7752a45f752a4a59c95853474dd363ed1960d20a340f17eb1815fda3aaf26d907dc30d37aa8c23608d718742b68864ca1bc
+DIST bx-python-0.12.0.gh.tar.gz 1660806 BLAKE2B 0eddb9b9a93520319d275001067a3518015483605cf4d096729ec92e14c0eb35f2ceb34db964216dd3c6687351a7415c46061960b1f66a7564c90efeba3a587b SHA512 821b33841dd2935485669f6c112277d404475b1cd778deb3eaa1194f3b21594335a219d9345e279e7afc3adb1e347e71e60f0029712fc58e95d1e70f9e8fbb55
diff --git a/sci-biology/bx-python/bx-python-0.12.0.ebuild b/sci-biology/bx-python/bx-python-0.12.0.ebuild
new file mode 100644
index 000000000..1a00b0395
--- /dev/null
+++ b/sci-biology/bx-python/bx-python-0.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for rapid implementation of genome scale analyses"
+HOMEPAGE="https://github.com/bxlab/bx-python"
+SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# doctests have external deps
+PATCHES=(
+ "${FILESDIR}/no-doctest.patch"
+)
+
+distutils_enable_tests pytest
+
+# https://github.com/bxlab/bx-python/issues/101
+EPYTEST_DESELECT=(
+ lib.linux-x86_64-cpython-312/bx/binned_array_tests.py::test_file_lzo
+ lib.linux-x86_64-cpython-312/bx/binned_array_tests.py::test_binned_array_writer
+)
+
+python_test() {
+ cd "${BUILD_DIR}/build" || die
+ ln -s "${S}/pytest.ini" . || die
+ ln -s "${S}/test_data" . || die
+ epytest
+}
diff --git a/sci-biology/bx-python/bx-python-0.8.9.ebuild b/sci-biology/bx-python/bx-python-0.8.9.ebuild
deleted file mode 100644
index 6cffba1be..000000000
--- a/sci-biology/bx-python/bx-python-0.8.9.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for rapid implementation of genome scale analyses"
-HOMEPAGE="https://github.com/bxlab/bx-python"
-SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
-# (and might need some more work beyond that)
-RESTRICT=test
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-# has file collision with sci-biology/RSeQC
-
-# ToDo: fix doc building:
-# Reason: TemplateNotFound('i')
-#distutils_enable_sphinx doc/source
-
-distutils_enable_tests pytest
diff --git a/sci-biology/bx-python/bx-python-0.9.0.ebuild b/sci-biology/bx-python/bx-python-0.9.0.ebuild
deleted file mode 100644
index 6cffba1be..000000000
--- a/sci-biology/bx-python/bx-python-0.9.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for rapid implementation of genome scale analyses"
-HOMEPAGE="https://github.com/bxlab/bx-python"
-SRC_URI="https://github.com/bxlab/bx-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
-# (and might need some more work beyond that)
-RESTRICT=test
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-# has file collision with sci-biology/RSeQC
-
-# ToDo: fix doc building:
-# Reason: TemplateNotFound('i')
-#distutils_enable_sphinx doc/source
-
-distutils_enable_tests pytest
diff --git a/sci-biology/bx-python/bx-python-9999.ebuild b/sci-biology/bx-python/bx-python-9999.ebuild
deleted file mode 100644
index b29975b58..000000000
--- a/sci-biology/bx-python/bx-python-9999.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..10} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Library for rapid implementation of genome scale analyses"
-HOMEPAGE="https://github.com/bxlab/bx-python"
-EGIT_REPO_URI="https://github.com/bxlab/bx-python"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-# Tests require dev-python/pytest-cython (currently not in ::gentoo or ::science)
-# (and might need some more work beyond that)
-RESTRICT=test
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-# has file collision with sci-biology/RSeQC
-
-# ToDo: fix doc building:
-# Reason: TemplateNotFound('i')
-#distutils_enable_sphinx doc/source
-
-distutils_enable_tests pytest
diff --git a/sci-biology/bx-python/files/no-doctest.patch b/sci-biology/bx-python/files/no-doctest.patch
new file mode 100644
index 000000000..d0c2b2e62
--- /dev/null
+++ b/sci-biology/bx-python/files/no-doctest.patch
@@ -0,0 +1,9 @@
+diff --git a/pytest.ini b/pytest.ini
+index e77e08f..4184247 100644
+--- a/pytest.ini
++++ b/pytest.ini
+@@ -1,4 +1,3 @@
+ [pytest]
+-addopts = --doctest-cython --doctest-modules
+ python_files = *_tests.py
+ testpaths = lib script_tests/
diff --git a/sci-biology/bx-python/metadata.xml b/sci-biology/bx-python/metadata.xml
index f1fc4360e..2ead27d78 100644
--- a/sci-biology/bx-python/metadata.xml
+++ b/sci-biology/bx-python/metadata.xml
@@ -5,10 +5,6 @@
<email>mschu.dev@gmail.com</email>
<name>Michael Schubert</name>
</maintainer>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
<upstream>
<remote-id type="github">bxlab/bx-python</remote-id>
<remote-id type="pypi">bx-python</remote-id>