aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2021-01-21 23:33:52 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-01-21 23:33:52 +0800
commit7bcde49d0dbfe5cee720e78e3e953646e770873b (patch)
treed0c64e9334521ae54772052d7c935ee6c9068257
parentdev-libs/protobuf: add back 3.11.* for PyTorch. (diff)
downloadsci-7bcde49d0dbfe5cee720e78e3e953646e770873b.tar.gz
sci-7bcde49d0dbfe5cee720e78e3e953646e770873b.tar.bz2
sci-7bcde49d0dbfe5cee720e78e3e953646e770873b.zip
dev-python/protobuf-python: add back 3.11.* for PyTorch.
PyTorch depends on protobuf-3.11.* which is removed from ::gentoo. Suggested-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--dev-python/protobuf-python/Manifest1
-rw-r--r--dev-python/protobuf-python/metadata.xml8
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild60
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
new file mode 100644
index 000000000..81632cac5
--- /dev/null
+++ b/dev-python/protobuf-python/Manifest
@@ -0,0 +1 @@
+DIST protobuf-3.11.4.tar.gz 5140799 BLAKE2B 97b450c0623593efe6a42b66582ff183344b8831689e6a5b4d36096dbd57c33da9569bbf26578536aaf73ecd866ac0588b6cb7d55a6a9b9a6e840d4c57099001 SHA512 777bbb0e9e2375eaebe6b8c87abd660bac70ee469c9ad00dd25917b82d7fb5bbe33cf87f0d69c90e19d55c07a7285ec20974ba4768623ce9ccfadf147fd5e261
diff --git a/dev-python/protobuf-python/metadata.xml b/dev-python/protobuf-python/metadata.xml
new file mode 100644
index 000000000..0d125ed97
--- /dev/null
+++ b/dev-python/protobuf-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <description>Gentoo Science Project</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild b/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild
new file mode 100644
index 000000000..2d5c57181
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-3.11.4-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2008-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/protocolbuffers/protobuf"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/22"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/protobuf-${PV}"
+RDEPEND="${BDEPEND}
+ !<dev-libs/protobuf-3[python(-)]"
+
+S="${WORKDIR}/protobuf-${PV}/python"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
+fi
+
+python_prepare_all() {
+ pushd "${WORKDIR}/protobuf-${PV}" > /dev/null || die
+ eapply "${FILESDIR}/${PN}-3.13.0-google.protobuf.pyext._message.PyUnknownFieldRef.patch"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=(--cpp_implementation)
+}
+
+python_compile() {
+ python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name "*.pth" -type f -delete || die
+}