aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 14:35:59 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:31 +0200
commit6a59b0bb6bb1bf48036cdea610c777ae040da3fc (patch)
treea02b2fb8fe6929631497921f0de249ab68af642d
parentdev-python/resample: new package, add 1.10.1 (diff)
downloadsci-6a59b0bb6bb1bf48036cdea610c777ae040da3fc.tar.gz
sci-6a59b0bb6bb1bf48036cdea610c777ae040da3fc.tar.bz2
sci-6a59b0bb6bb1bf48036cdea610c777ae040da3fc.zip
dev-python/histoprint: add 2.5.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--dev-python/histoprint/Manifest1
-rw-r--r--dev-python/histoprint/histoprint-2.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/histoprint/Manifest b/dev-python/histoprint/Manifest
index 2914a2419..c08f978b9 100644
--- a/dev-python/histoprint/Manifest
+++ b/dev-python/histoprint/Manifest
@@ -1 +1,2 @@
DIST histoprint-2.4.0.tar.gz 359154 BLAKE2B f10abcff02875f1a27b31256c5daf00500e0177986052f3fc9b013a0be0f63daf58f9d9b7bf2b6b5510758e080a118c6ad07801b055019e7e226ee631da57154 SHA512 bbf7c90acb66c298588304a15c7ae3ec0536fb01a468b4aa7b944115e242a0ef3e2ef21c181e8476845f5d7611a944f43de0c9cf80faeab2ddbb8422432e2fa6
+DIST histoprint-2.5.0.tar.gz 360296 BLAKE2B 37a40cfea760a08c0dcfc89d51eb526ee4bdb8c01cca18b2450f0f54ae61e051d4d8331227c05b6db85b7cf3553660e17dd68ed95d47021a874614de16958627 SHA512 e08063f58afbae570721ecbb91f772998d374b50d61d9622ef0c6ff96272711c49cb04d1882befba6ed54ce7933c9bb24fc5ac9fd83b16c43bdd96b135b9828e
diff --git a/dev-python/histoprint/histoprint-2.5.0.ebuild b/dev-python/histoprint/histoprint-2.5.0.ebuild
new file mode 100644
index 000000000..55286dfc5
--- /dev/null
+++ b/dev-python/histoprint/histoprint-2.5.0.ebuild
@@ -0,0 +1,26 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pretty print histograms to the console"
+HOMEPAGE="https://github.com/scikit-hep/histoprint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/click-7.0.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/uhi-0.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/awkward-1[${PYTHON_USEDEP}]
+ >=sci-physics/uproot-4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest