summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2010-07-21 00:24:19 +0200
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2010-07-21 00:24:19 +0200
commit693832af2ba03278b528b6714fcef131666bdd79 (patch)
treedcff27e43d6701f38606ad2da2b5c1b550a4c41d
parentAdd patches for the new ruby 1.9 release. (diff)
downloadruby-scripts-1.9.2_rc2-r0.tar.gz
ruby-scripts-1.9.2_rc2-r0.tar.bz2
ruby-scripts-1.9.2_rc2-r0.zip
Add patches for 1.9.2_rc2.1.9.2_rc2-r0
-rw-r--r--patchsets/patches-1.9.2_rc2/004_gfbsd7.patch39
-rw-r--r--patchsets/patches-1.9.2_rc2/005_no-undefined-ext.patch13
-rw-r--r--patchsets/patches-1.9.2_rc2/006_no-rake.patch12
-rw-r--r--patchsets/patches-1.9.2_rc2/series3
4 files changed, 67 insertions, 0 deletions
diff --git a/patchsets/patches-1.9.2_rc2/004_gfbsd7.patch b/patchsets/patches-1.9.2_rc2/004_gfbsd7.patch
new file mode 100644
index 0000000..d5c2fea
--- /dev/null
+++ b/patchsets/patches-1.9.2_rc2/004_gfbsd7.patch
@@ -0,0 +1,39 @@
+Index: ruby-1.9.2-rc2/configure.in
+===================================================================
+--- ruby-1.9.2-rc2.orig/configure.in
++++ ruby-1.9.2-rc2/configure.in
+@@ -1683,7 +1683,7 @@ if test "$rb_cv_binary_elf" = yes; then
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -1772,7 +1772,7 @@ if test "$with_dln_a_out" != yes; then
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -1785,7 +1785,6 @@ if test "$with_dln_a_out" != yes; then
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
+@@ -2066,7 +2065,7 @@ if test "$enable_shared" = 'yes'; then
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
diff --git a/patchsets/patches-1.9.2_rc2/005_no-undefined-ext.patch b/patchsets/patches-1.9.2_rc2/005_no-undefined-ext.patch
new file mode 100644
index 0000000..1a4ca31
--- /dev/null
+++ b/patchsets/patches-1.9.2_rc2/005_no-undefined-ext.patch
@@ -0,0 +1,13 @@
+Index: ruby-1.9.2-rc2/configure.in
+===================================================================
+--- ruby-1.9.2-rc2.orig/configure.in
++++ ruby-1.9.2-rc2/configure.in
+@@ -1775,7 +1775,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-1.9.2_rc2/006_no-rake.patch b/patchsets/patches-1.9.2_rc2/006_no-rake.patch
new file mode 100644
index 0000000..8107c75
--- /dev/null
+++ b/patchsets/patches-1.9.2_rc2/006_no-rake.patch
@@ -0,0 +1,12 @@
+Index: ruby-1.9.2-rc2/tool/rbinstall.rb
+===================================================================
+--- ruby-1.9.2-rc2.orig/tool/rbinstall.rb
++++ ruby-1.9.2-rc2/tool/rbinstall.rb
+@@ -504,7 +504,6 @@ install?(:ext, :comm, :gem) do
+
+ destdir = File.join(gpath, directories.grep(/^spec/)[0])
+ default_gems = [
+- ['rake', 'rake.rb'],
+ ['rdoc', 'rdoc.rb'],
+ ['minitest', 'minitest/unit.rb'],
+ ]
diff --git a/patchsets/patches-1.9.2_rc2/series b/patchsets/patches-1.9.2_rc2/series
new file mode 100644
index 0000000..75c9072
--- /dev/null
+++ b/patchsets/patches-1.9.2_rc2/series
@@ -0,0 +1,3 @@
+004_gfbsd7.patch
+005_no-undefined-ext.patch
+006_no-rake.patch