aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-08-20 10:46:33 +0100
committerSam James <sam@gentoo.org>2023-08-21 13:24:01 +0100
commit104d649f2bfeac0c17db8fdd46653efeb6eab7d2 (patch)
tree5e7483ed0d7077cd99c3028fad87dd7cb7e282c0 /pyproject.toml
parentbintree: Add invalid_paths member to API (diff)
downloadportage-104d649f2bfeac0c17db8fdd46653efeb6eab7d2.tar.gz
portage-104d649f2bfeac0c17db8fdd46653efeb6eab7d2.tar.bz2
portage-104d649f2bfeac0c17db8fdd46653efeb6eab7d2.zip
Allow building of pure Python wheel by setting "pure" appropriately
It will only build a pure wheel when pure is true in all cases. Signed-off-by: James Le Cuirot <chewi@gentoo.org> Closes: https://github.com/gentoo/portage/pull/1082 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 635fca25c..eb725e1c5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -14,6 +14,8 @@ build-backend = 'mesonpy'
requires = ['meson-python']
[tool.meson-python.args]
+# To get a pure wheel:
+# python -m build --wheel -Csetup-args="-Dnative-extensions=false"
setup = ['-Dsystem-wide=false']
[project.scripts]