aboutsummaryrefslogtreecommitdiff
path: root/quse.c
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-01-02 12:17:53 +0100
committerFabian Groffen <grobian@gentoo.org>2020-01-02 12:17:53 +0100
commit24e232b949803a0d650387c61eb32c95d7270647 (patch)
treeff585c3918d76d1a2390d924f4b366c3b5013fd7 /quse.c
parentlibq/atom: also strip/ignore .tbz2 suffix (like .ebuild) (diff)
downloadportage-utils-24e232b949803a0d650387c61eb32c95d7270647.tar.gz
portage-utils-24e232b949803a0d650387c61eb32c95d7270647.tar.bz2
portage-utils-24e232b949803a0d650387c61eb32c95d7270647.zip
libq/tree: have tree_foreach_pkg take a query atom
Allow to reduce the search by having a query atom. This will skip categories and packages not matching the atom, possibly avoiding lots of work. This needs to be exploited from applets where necessary. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'quse.c')
-rw-r--r--quse.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/quse.c b/quse.c
index be34e48b..a8585bef 100644
--- a/quse.c
+++ b/quse.c
@@ -1,5 +1,5 @@
/*
- * Copyright 2005-2019 Gentoo Foundation
+ * Copyright 2005-2020 Gentoo Foundation
* Distributed under the terms of the GNU General Public License v2
*
* Copyright 2005-2010 Ned Ludd - <solar@gentoo.org>
@@ -719,14 +719,14 @@ int quse_main(int argc, char **argv)
} else if (state.do_installed) {
tree_ctx *t = tree_open_vdb(portroot, portvdb);
state.overlay = NULL;
- tree_foreach_pkg_sorted(t, quse_results_cb, &state);
+ tree_foreach_pkg_sorted(t, quse_results_cb, &state, NULL);
tree_close(t);
} else {
array_for_each(overlays, n, overlay) {
tree_ctx *t = tree_open(portroot, overlay);
state.overlay = overlay;
if (t != NULL) {
- tree_foreach_pkg_sorted(t, quse_results_cb, &state);
+ tree_foreach_pkg_sorted(t, quse_results_cb, &state, NULL);
tree_close(t);
}
}