aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2010-08-03 20:13:39 -0700
committerBrian Harring <ferringb@gmail.com>2010-08-03 20:13:39 -0700
commit1af4d4f98b9c5f3993d03ac38863dae6cd1ac7bf (patch)
tree4cc3f1bdad847a0f0b4f4a7a28041eb2b143c8fc /doc
parentremoval of some epytext, and making api/*.rst autogeneration fast, and mtime ... (diff)
downloadsnakeoil-1af4d4f98b9c5f3993d03ac38863dae6cd1ac7bf.tar.gz
snakeoil-1af4d4f98b9c5f3993d03ac38863dae6cd1ac7bf.tar.bz2
snakeoil-1af4d4f98b9c5f3993d03ac38863dae6cd1ac7bf.zip
disable autogeneration of autosummary targets, set the version to trunk
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile4
-rw-r--r--doc/conf.py6
2 files changed, 5 insertions, 5 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 7a80fa2..8fc9b31 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -15,7 +15,7 @@ export SNAKEOIL_DEMANDLOAD_WARN = no
export SNAKEOIL_DEMANDLOAD_PROTECTION = no
export PYTHONPATH=../
-.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest generated
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest generated api
help:
@echo "Please use \`make <target>' where <target> is one of"
@@ -43,7 +43,7 @@ generated: api
api:
@echo "autogenerating api rsts..."
- @mkdir api -p
+ @mkdir -p api
@for fn in `cat public_modules.txt`; \
do echo $${fn} api/$${fn}.rst; \
done | ./generate_api_rsts.py
diff --git a/doc/conf.py b/doc/conf.py
index 653b1b7..845eda5 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -53,9 +53,9 @@ copyright = u'2010, Brian Harring'
# built documents.
#
# The short X.Y version.
-version = '0.3.7'
+version = '-trunk'
# The full version, including alpha/beta/rc tags.
-release = '0.3.7'
+release = '-trunk'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
@@ -225,7 +225,7 @@ man_pages = [
# Example configuration for intersphinx: refer to the Python standard library.
intersphinx_mapping = {'http://docs.python.org/': None}
autodoc_default_flags = ['members', 'show-inheritance', 'inherited-members'] # + ['undoc-members']
-autosummary_generate = True
+autosummary_generate = False
extlinks = {"snakeoil_home":("http://pkgcore.org/snakeoil",''),
"snakeoil_release":("http://pkgcore.org/trac/snakeoil/",'trac'),