aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2024-01-12 23:27:03 -0500
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-15 08:32:50 +0200
commit1cf6d7caf82fc92aa72e4cd0d9c5815b160db5d3 (patch)
treed647c8e56c8f8a20f3f89c0900d2f75ba0a173e8
parentci: run pmaint regen over ::gentoo repo (diff)
downloadpkgcore-1cf6d7caf82fc92aa72e4cd0d9c5815b160db5d3.tar.gz
pkgcore-1cf6d7caf82fc92aa72e4cd0d9c5815b160db5d3.tar.bz2
pkgcore-1cf6d7caf82fc92aa72e4cd0d9c5815b160db5d3.zip
Write LICENSE before SLOT in create_ebuild()
Better matches the order defined in skel.ebuild A prerequisite for https://github.com/pkgcore/pkgcheck/pull/645 Signed-off-by: Anthony Ryan <anthonyryan1@gmail.com> Closes: https://github.com/pkgcore/pkgcore/pull/425 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--src/pkgcore/pytest/plugin.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/pkgcore/pytest/plugin.py b/src/pkgcore/pytest/plugin.py
index 6578050e2..0579a45ad 100644
--- a/src/pkgcore/pytest/plugin.py
+++ b/src/pkgcore/pytest/plugin.py
@@ -263,14 +263,14 @@ class EbuildRepo:
f.write(f"EAPI={eapi}\n\n")
f.write(f'DESCRIPTION="{desc}"\n')
f.write(f'HOMEPAGE="{homepage}"\n')
- f.write(f'SLOT="{slot}"\n')
-
if license:
f.write(f'LICENSE="{license}"\n')
# create a fake license
os.makedirs(pjoin(self.path, "licenses"), exist_ok=True)
touch(pjoin(self.path, "licenses", license))
+ f.write(f'SLOT="{slot}"\n')
+
for k, v in kwargs.items():
# handle sequences such as KEYWORDS and IUSE
if isinstance(v, (tuple, list)):