summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/nats/nats-9999.ebuild')
-rw-r--r--dev-lua/nats/nats-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lua/nats/nats-9999.ebuild b/dev-lua/nats/nats-9999.ebuild
new file mode 100644
index 0000000..a297405
--- /dev/null
+++ b/dev-lua/nats/nats-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+GITHUB_A="dawnangel"
+GITHUB_PN="lua-${PN}"
+
+inherit lua
+
+DESCRIPTION="Lua client for NATS messaging system"
+HOMEPAGE="https://github.com/dawnangel/lua-nats"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples"
+
+RDEPEND="
+ dev-lua/lua-cjson
+ dev-lua/luasocket
+ dev-lua/uuid
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=(README.md)
+#HTML_DOCS=(docs/.)
+EXAMPLES=({examples,tests}/.)
+
+#all_lua_compile() {
+# use doc && ldoc .
+#}
+#
+#each_lua_compile() { :; }
+# Makefile is only used to run tests
+# and ldoc is currently broken
+src_compile() { :; }
+
+each_lua_install() {
+ dolua "src/${PN}.lua"
+}