summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-udev/lua-udev-9999.ebuild')
-rw-r--r--dev-lua/lua-udev/lua-udev-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lua/lua-udev/lua-udev-9999.ebuild b/dev-lua/lua-udev/lua-udev-9999.ebuild
new file mode 100644
index 0000000..a65be4d
--- /dev/null
+++ b/dev-lua/lua-udev/lua-udev-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+IS_MULTILIB=true
+VCS="git"
+GITHUB_A="dodo"
+
+inherit lua
+
+DESCRIPTION="udev bindings for Lua"
+HOMEPAGE="https://github.com/dodo/lua-udev/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples"
+
+EXAMPLES=(test.lua)
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ virtual/libudev
+"
+
+each_lua_compile() {
+ _lua_setFLAGS
+ ${CC} "${PN}.c" ${CFLAGS} ${LUA_CF} ${LDFLAGS} ${LUA_LF} -ludev -o udev.so
+}
+
+each_lua_install() {
+ dolua udev.so
+}