summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2018-09-23 13:40:50 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2018-09-23 13:40:50 +0700
commit5245fafe76da19556d9866a0339a9c5022aec0ed (patch)
tree62da6354d1bf8111a17490f228a07d5883570922
parentlua.eclass: prepare() mod (diff)
downloadlua-5245fafe76da19556d9866a0339a9c5022aec0ed.tar.gz
lua-5245fafe76da19556d9866a0339a9c5022aec0ed.tar.bz2
lua-5245fafe76da19556d9866a0339a9c5022aec0ed.zip
ldbus: added
-rw-r--r--dev-lua/ldbus/files/GNUmakefile6
-rw-r--r--dev-lua/ldbus/ldbus-9999.ebuild45
-rw-r--r--dev-lua/ldbus/metadata.xml14
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-lua/ldbus/files/GNUmakefile b/dev-lua/ldbus/files/GNUmakefile
new file mode 100644
index 0000000..f06efae
--- /dev/null
+++ b/dev-lua/ldbus/files/GNUmakefile
@@ -0,0 +1,6 @@
+TOPTARGETS := all clean install
+.PHONY: $(TOPTARGETS)
+
+$(TOPTARGETS):
+ $(MAKE) -C src $@ $(MAKECMDGOALS)
+
diff --git a/dev-lua/ldbus/ldbus-9999.ebuild b/dev-lua/ldbus/ldbus-9999.ebuild
new file mode 100644
index 0000000..2f6319e
--- /dev/null
+++ b/dev-lua/ldbus/ldbus-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+IS_MULTILIB=true
+VCS="git"
+GITHUB_A="daurnimator"
+
+inherit lua
+
+DESCRIPTION="A Lua library to access dbus"
+HOMEPAGE="https://github.com/daurnimator/ldbus/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples"
+
+DOCS=(README.md)
+EXAMPLES=(example.lua)
+
+RDEPEND="
+ sys-apps/dbus
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+all_lua_prepare() {
+ cp "${FILESDIR}/GNUmakefile" "${S}/"
+ sed -r \
+ -e '1iinclude ../.lua_eclass_config' \
+ -e 's@lua5.3@$(LUA_IMPL)@' \
+ -e '/^PKG_CONFIG/d' \
+ -e '/^LUA_LIBDIR/d' \
+ -e '/install:/,${s@(\$\(LUA_LIBDIR\))@$(DESTDIR)/\1@g}' \
+ -i src/Makefile
+ lua_default
+}
+
+each_lua_install() {
+ dolua src/{message,"${PN}".so}
+}
diff --git a/dev-lua/ldbus/metadata.xml b/dev-lua/ldbus/metadata.xml
new file mode 100644
index 0000000..c1baef2
--- /dev/null
+++ b/dev-lua/ldbus/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ lightweight, native, lazy evaluating multithreading library for Lua-5.1 or 5.2.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">LuaLanes/lanes</remote-id>
+ </upstream>
+</pkgmetadata>