aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-02-03 15:57:59 -0800
committerBrian Dolbec <dolsen@gentoo.org>2015-02-07 12:48:38 -0800
commit9b482adc47992eb2df830d906be57330acc89fa2 (patch)
tree61e79b085023dbe3d8cabe61722cc40e48a8afb8 /setup.py
parentversion bump (diff)
downloadlayman-9b482adc47992eb2df830d906be57330acc89fa2.tar.gz
layman-9b482adc47992eb2df830d906be57330acc89fa2.tar.bz2
layman-9b482adc47992eb2df830d906be57330acc89fa2.zip
Move the plugin module into a portage namespace for installation
But to avoid import conflicts during testing in the checkout, move it to a pm_plugins subdir.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8a815eb..21a387a 100755
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,7 @@ import sys
from distutils.core import setup
+
# this affects the names of all the directories we do stuff with
sys.path.insert(0, './')
from layman.version import VERSION
@@ -27,7 +28,7 @@ SELECTABLE = {
use_defaults = ' '.join(list(SELECTABLE))
SYNC_PLUGINS = {
- 'sync-plugin-portage': 'layman.laymanator',
+ 'sync-plugin-portage': 'portage.sync.modules.laymansync',
}
# get the USE from the environment, default to all selectable modules