aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kopete/Manifest6
-rw-r--r--kde-base/kopete/kopete-4.2.69.ebuild14
-rw-r--r--kde-base/kopete/kopete-4.2.69.ebuild.orig139
-rw-r--r--kde-base/kopete/kopete-9999.ebuild14
-rw-r--r--kde-base/kopete/kopete-9999.ebuild.orig139
5 files changed, 292 insertions, 20 deletions
diff --git a/kde-base/kopete/Manifest b/kde-base/kopete/Manifest
index 1eb4582736..756f6bd148 100644
--- a/kde-base/kopete/Manifest
+++ b/kde-base/kopete/Manifest
@@ -1,5 +1,7 @@
DIST kdenetwork-4.2.69.tar.lzma 6349626 RMD160 2d3660c51ce5d944efba598cf7d9c9ee7a4e263e SHA1 a38c50b134763b98a9b3e585fdc01f5a32eb8380 SHA256 77eb2041cf54764064b1404529c543db3116578a2a247bea3393722376d5f9d8
-EBUILD kopete-4.2.69.ebuild 3555 RMD160 d5e28fb3adc898a018f0aca9009e7af8872c5479 SHA1 cae4135e59903d3aab9cad60a6426e56222b3b46 SHA256 95cc1657f9d7776050e06bd4222933f3096647358e04fe30027400946256ba70
-EBUILD kopete-9999.ebuild 3531 RMD160 8f482e9a880d431214841e5833462234f8a2f99c SHA1 2f329011debf05e85ce4eed877bce8a65e9b292d SHA256 b27d1e30b1cb9711b347d168e8a6b389a6ab18a60d516ad82460f13d109ecc1c
+EBUILD kopete-4.2.69.ebuild 3461 RMD160 f4683dd12c62a6910d6fd7ecd76eab41a7a84fdc SHA1 81278cc130d6fb92506005433df8836a4e2f5b02 SHA256 0d722e79ec44ee9b63ee9dad99ca9d60a506688bdf358abe592dbfe88a987c81
+EBUILD kopete-9999.ebuild 3437 RMD160 1ab0ff5b79a2f25ac5224cd01c8aaf93f2fb837f SHA1 5c4a8d8e41c52eb7478c508b514c0ef1ce8be528 SHA256 c60285194bf1a0b2398a1f6d2d963fca8b39b301e49507d503671273ee0d4d8e
MISC ChangeLog 6639 RMD160 096293ecf4bd4b8a124b1a8e33ba04d12ac4fdbc SHA1 8ee67f25cfddc03a2291004cf1973918d9e7bb80 SHA256 a63126234cc6ee32a82a3209fc36d2b0f2ad6059e64e3a5f76e8f76eb6436109
+MISC kopete-4.2.69.ebuild.orig 3523 RMD160 da3712d90e40ea7bb0e016983b72b05311a5527e SHA1 1bfe50b8f2db495f446b91bb0e81d2251ee80399 SHA256 15ef89664170e50f433e9b3d54aeb538f0a498a9d5d5742f9ebedab5b51e8a76
+MISC kopete-9999.ebuild.orig 3499 RMD160 a3857fff92bcd8ee339a15398d2bb6a32a1ca974 SHA1 8b4c675ff43a68b296576c40e9a475add99eeb69 SHA256 dd4c2707cd6b1be1c8265bf3d925a023ba2cdae65a25b4f82dff95fe9ec6367a
MISC metadata.xml 2757 RMD160 f457dce40f26718ca207eaf9e652526ab1220e28 SHA1 bf1be31a903d422445393de48124ea1894ed8b6e SHA256 187d383c288460ea47b32bd45c31b50803a65189e92114260e9bdea03d9d8c15
diff --git a/kde-base/kopete/kopete-4.2.69.ebuild b/kde-base/kopete/kopete-4.2.69.ebuild
index efe0705fb6..1ea998bd20 100644
--- a/kde-base/kopete/kopete-4.2.69.ebuild
+++ b/kde-base/kopete/kopete-4.2.69.ebuild
@@ -59,9 +59,6 @@ testbed winpopup yahoo"
IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
-# Tests are KDE-ish.
-RESTRICT="test"
-
COMMONDEPEND="
dev-libs/libpcre
x11-libs/libXScrnSaver
@@ -97,14 +94,13 @@ PDEPEND="
"
src_configure() {
- local x
- # Xmms isn't in portage, thus forcefully disabled.
- # Also disable old msn support.
- mycmakeargs="${mycmakeargs} -DWITH_Xmms=OFF -DWITH_msn=OFF"
+ local x x2
+ # Disable old msn support.
+ mycmakeargs="${mycmakeargs} -DWITH_msn=OFF"
# enable protocols
for x in ${PROTOCOLS}; do
- [[ ${x/+/} = msn ]] && x="wlm"
- mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ [[ ${x/+/} = msn ]] && x2=wlm || x2=""
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/} ${x2})"
done
# enable plugins
for x in ${PLUGINS}; do
diff --git a/kde-base/kopete/kopete-4.2.69.ebuild.orig b/kde-base/kopete/kopete-4.2.69.ebuild.orig
new file mode 100644
index 0000000000..6fc9548741
--- /dev/null
+++ b/kde-base/kopete/kopete-4.2.69.ebuild.orig
@@ -0,0 +1,139 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="debug doc ssl"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +alias +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# bonjour: NO DEPS
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# qq: NO DEPS
+# sms: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS
+# yahoo: NO DEPS
+PROTOCOLS="bonjour gadu groupwise +jabber jingle meanwhile msn oscar qq
+testbed winpopup yahoo"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ x11-libs/libXScrnSaver
+ >=x11-libs/qt-gui-4.4.0:4[mng]
+ gadu? ( >=net-libs/libgadu-1.8.0 )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ jingle? (
+ >=media-libs/speex-1.2_rc1
+ >=net-libs/ortp-0.13
+ )
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( net-libs/libmsn )
+ otr? ( net-libs/libotr )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto
+"
+PDEPEND="
+ ssl? ( app-crypt/qca-ossl )
+"
+
+src_configure() {
+ local x
+ # Xmms isn't in portage, thus forcefully disabled.
+ # Also disable old msn support.
+ mycmakeargs="${mycmakeargs} -DWITH_Xmms=OFF -DWITH_msn=OFF"
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ [[ ${x/+/} = msn ]] && ${x/+/} = wlm
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+ # additional defines
+ if use jingle && ! use jabber; then
+ elog "You enabled jingle but not jabber useflag. Jingle is integral part of"
+ elog "jabber protocol so it wont be used."
+ fi
+ if use jabber; then
+ mycmakeargs="${mycmakeargs} -DNO_JINGLE=$(use jingle && echo OFF || echo ON)"
+ fi
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+ #fi
+
+ if ! use ssl; then
+ if use jabber || use msn; then # || use irc; then
+ echo
+ elog "In order to use ssl in jabber, msn and irc you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}
diff --git a/kde-base/kopete/kopete-9999.ebuild b/kde-base/kopete/kopete-9999.ebuild
index 054e25c2d5..9af7015bd1 100644
--- a/kde-base/kopete/kopete-9999.ebuild
+++ b/kde-base/kopete/kopete-9999.ebuild
@@ -59,9 +59,6 @@ testbed winpopup yahoo"
IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
-# Tests are KDE-ish.
-RESTRICT="test"
-
COMMONDEPEND="
dev-libs/libpcre
x11-libs/libXScrnSaver
@@ -97,14 +94,13 @@ PDEPEND="
"
src_configure() {
- local x
- # Xmms isn't in portage, thus forcefully disabled.
- # Also disable old msn support.
- mycmakeargs="${mycmakeargs} -DWITH_Xmms=OFF -DWITH_msn=OFF"
+ local x x2
+ # Disable old msn support.
+ mycmakeargs="${mycmakeargs} -DWITH_msn=OFF"
# enable protocols
for x in ${PROTOCOLS}; do
- [[ ${x/+/} = msn ]] && x="wlm"
- mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ [[ ${x/+/} = msn ]] && x2=wlm || x2=""
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/} ${x2})"
done
# enable plugins
for x in ${PLUGINS}; do
diff --git a/kde-base/kopete/kopete-9999.ebuild.orig b/kde-base/kopete/kopete-9999.ebuild.orig
new file mode 100644
index 0000000000..1875760895
--- /dev/null
+++ b/kde-base/kopete/kopete-9999.ebuild.orig
@@ -0,0 +1,139 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS=""
+IUSE="debug doc ssl"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +alias +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# bonjour: NO DEPS
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# qq: NO DEPS
+# sms: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS
+# yahoo: NO DEPS
+PROTOCOLS="bonjour gadu groupwise +jabber jingle meanwhile msn oscar qq
+testbed winpopup yahoo"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ x11-libs/libXScrnSaver
+ >=x11-libs/qt-gui-4.4.0:4[mng]
+ gadu? ( >=net-libs/libgadu-1.8.0 )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ jingle? (
+ >=media-libs/speex-1.2_rc1
+ >=net-libs/ortp-0.13
+ )
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( net-libs/libmsn )
+ otr? ( net-libs/libotr )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto
+"
+PDEPEND="
+ ssl? ( app-crypt/qca-ossl )
+"
+
+src_configure() {
+ local x
+ # Xmms isn't in portage, thus forcefully disabled.
+ # Also disable old msn support.
+ mycmakeargs="${mycmakeargs} -DWITH_Xmms=OFF -DWITH_msn=OFF"
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ [[ ${x/+/} = msn ]] && ${x/+/} = wlm
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+ # additional defines
+ if use jingle && ! use jabber; then
+ elog "You enabled jingle but not jabber useflag. Jingle is integral part of"
+ elog "jabber protocol so it wont be used."
+ fi
+ if use jabber; then
+ mycmakeargs="${mycmakeargs} -DNO_JINGLE=$(use jingle && echo OFF || echo ON)"
+ fi
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+ #fi
+
+ if ! use ssl; then
+ if use jabber || use msn; then # || use irc; then
+ echo
+ elog "In order to use ssl in jabber, msn and irc you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}