aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-03 20:41:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-03 21:24:01 +0100
commit17fb9d8b4d174fd4fa88ba81aaaa9016191d28dd (patch)
tree62b7da700cc0382fd70995e28a377e90f4fd3552 /kde-frameworks/kauth
parentkde-plasma/kwayland: 5.115.0 version bump (diff)
downloadkde-17fb9d8b4d174fd4fa88ba81aaaa9016191d28dd.tar.gz
kde-17fb9d8b4d174fd4fa88ba81aaaa9016191d28dd.tar.bz2
kde-17fb9d8b4d174fd4fa88ba81aaaa9016191d28dd.zip
kde-frameworks/kauth: 5.115.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.115.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
new file mode 100644
index 0000000000..77b522c427
--- /dev/null
+++ b/kde-frameworks/kauth/Manifest
@@ -0,0 +1 @@
+DIST kauth-5.115.0.tar.xz 2307844 BLAKE2B a4d8ec60f0cc4728ea42b876c1f3b7a233280b99d8ff5608297e80920e6c1a287839c4a88916d0e19121a49d2d47c9c2c049c93b490b4cfed31b4d67ab79a300 SHA512 ace9bcefdba0425dc4e2fc4dfe90bd8faad91b1e5b6ed16ec5b7870f3f22e4384d4b1776c97da501eefb5dc7ed31412593c59a5567cb394e11838d8cfe118fde
diff --git a/kde-frameworks/kauth/kauth-5.115.0.ebuild b/kde-frameworks/kauth/kauth-5.115.0.ebuild
new file mode 100644
index 0000000000..7965acd201
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.115.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+policykit"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ policykit? ( >=sys-auth/polkit-qt-0.113.0[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent:* )"
+
+CMAKE_SKIP_TESTS=(
+ # KAuthHelperTest test fails, bug 654842
+ KAuthHelperTest
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package policykit PolkitQt5-1)
+ )
+
+ ecm_src_configure
+}