aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-17 22:10:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-20 13:09:30 +0200
commitced087cedc5e0fe787a4f1ac3a43e5ba65e5a9d8 (patch)
tree85f4c5c0af5cc031009ef01160ba64c62b62c163 /kde-apps/dolphin-plugins-dropbox
parentmedia-sound/krecorder: 24.05.0 version bump (diff)
downloadkde-ced087cedc5e0fe787a4f1ac3a43e5ba65e5a9d8.tar.gz
kde-ced087cedc5e0fe787a4f1ac3a43e5ba65e5a9d8.tar.bz2
kde-ced087cedc5e0fe787a4f1ac3a43e5ba65e5a9d8.zip
kde-apps/dolphin-plugins-dropbox: 24.05.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.05.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index f48ed1be4b..0fed7d7dc9 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-24.04.90.tar.xz 304688 BLAKE2B 9cb14275badd693abc2dab46f4e9192c63ff0e01ba0f7d5356df14b7c9fdb93c58e6b2fe22e4bd384c7a39457697fc3087093287c357758f86e1d9bb0f1cafc9 SHA512 94bd585ba80304728b228f2a2e623b5f05ecb4a73a80806aa47b4bd6506ec4a7aea52cdeebd3f31de80efe4cd8d2bcaf805de89abd736f87600726593224f5da
+DIST dolphin-plugins-24.05.0.tar.xz 304784 BLAKE2B dfd61af9d8cd6aa66b9295e7da343c6f077a7aed838b002eb055af29e66b6425f2dd8562f5a8a088dc39f2f73d42f5614f668c4e848435412bca7c2f6259ea11 SHA512 1d36fae869f5afabd394433f69e83fd603981ebef3d564f04e45cade250c6ccd54edc4e493339201aaea9d415fc87bf031485853619a9298ae86dffa1972e256
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.05.0.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.05.0.ebuild
new file mode 100644
index 0000000000..635b93e614
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.05.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}