aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-03 09:58:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-03 10:13:20 +0100
commitbea6beadeada84e7639c5838251c205c54807259 (patch)
treecf4f1d94ccdfb2a51e702740b48ef23cfae2071c /dev-libs
parentapp-office/kalendar: 22.12.1 version bump (diff)
downloadkde-bea6beadeada84e7639c5838251c205c54807259.tar.gz
kde-bea6beadeada84e7639c5838251c205c54807259.tar.bz2
kde-bea6beadeada84e7639c5838251c205c54807259.zip
dev-libs/kopeninghours: 22.12.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-22.12.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
new file mode 100644
index 0000000000..16df2f72a0
--- /dev/null
+++ b/dev-libs/kopeninghours/Manifest
@@ -0,0 +1 @@
+DIST kopeninghours-22.12.1.tar.xz 71108 BLAKE2B a7cadeacb56e58ec5412df900ddc701f49105b0f88e1d6c1ee2a13922899375561e8a7f15ff809cca9fbc3a422843372b2b7653b73ae97406c6a78b3e7cd5940 SHA512 6c7769611bf5a745902f45d3af1d236205e21338c5be8936eb9d2e2ee1de67a7231c45b3c5568b63437d22eab32e91e7f36a2b63898baae984ae3f2712cca28d
diff --git a/dev-libs/kopeninghours/kopeninghours-22.12.1.ebuild b/dev-libs/kopeninghours/kopeninghours-22.12.1.ebuild
new file mode 100644
index 0000000000..321f5afa98
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-22.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.101.0
+QTMIN=5.15.5
+PYTHON_COMPAT=( python3_{8..11} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}