aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 15:17:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 18:30:34 +0100
commit17454ad507731cf37eb5f0e73464dca650a34dcf (patch)
tree50ce5ee535ec628471107fca2929d32c2a231778
parentkde-apps/libktnef: 24.11.80 version bump (diff)
downloadkde-17454ad507731cf37eb5f0e73464dca650a34dcf.tar.gz
kde-17454ad507731cf37eb5f0e73464dca650a34dcf.tar.bz2
kde-17454ad507731cf37eb5f0e73464dca650a34dcf.zip
kde-apps/mailcommon: 24.11.80 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/mailcommon/Manifest1
-rw-r--r--kde-apps/mailcommon/mailcommon-24.11.80.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/mailcommon/Manifest b/kde-apps/mailcommon/Manifest
new file mode 100644
index 0000000000..37967671d9
--- /dev/null
+++ b/kde-apps/mailcommon/Manifest
@@ -0,0 +1 @@
+DIST mailcommon-24.11.80.tar.xz 789680 BLAKE2B f01744ff1031d61f180a2b9cafb2fa56e32b698474e981c10ef89f8ba6021f43dc9973e3b2b5aaec147e7fd6faa0daa46ba91395c02330e5274a6882c9fb4773 SHA512 7e30572abe5c58a483f89f4481ae8aa5b52a28461abdc1c51dc6cd811b2ff8ca03d9f581493cd9cd58be7ac65133f25d6063107a34fbaac13a526e4d2cb6d1c7
diff --git a/kde-apps/mailcommon/mailcommon-24.11.80.ebuild b/kde-apps/mailcommon/mailcommon-24.11.80.ebuild
new file mode 100644
index 0000000000..7ea677de6b
--- /dev/null
+++ b/kde-apps/mailcommon/mailcommon-24.11.80.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_QTHELP="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Common mail library"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="activities"
+
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.23.1-r1:=[cxx,qt6]
+ >=dev-libs/ktextaddons-1.5.4:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets,xml]
+ >=dev-qt/qtmultimedia-${QTMIN}:6
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/akonadi-mime-${PVCUT}:6
+ >=kde-apps/kmailtransport-${PVCUT}:6
+ >=kde-apps/kmime-${PVCUT}:6
+ >=kde-apps/kpimtextedit-${PVCUT}:6
+ >=kde-apps/libkdepim-${PVCUT}:6
+ >=kde-apps/mailimporter-${PVCUT}:6
+ >=kde-apps/messagelib-${PVCUT}:6
+ >=kde-apps/pimcommon-${PVCUT}:6[activities?]
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcodecs-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:6
+ >=media-libs/phonon-4.12.0[qt6(+)]
+ activities? ( kde-plasma/plasma-activities:6 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPTION_USE_PLASMA_ACTIVITIES=$(usex activities)
+ )
+ ecm_src_configure
+}