aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-05-30 11:23:06 -0400
committerMike Frysinger <vapier@gentoo.org>2014-05-30 11:23:06 -0400
commitc88863f56042f31b52b9aee45f87a77a5f287b61 (patch)
tree6a2af4655f0bf802210936b017ecee0a1fdab77b /Makefile
parentrespect $PKG_CONFIG env var (diff)
downloadhwids-c88863f56042f31b52b9aee45f87a77a5f287b61.tar.gz
hwids-c88863f56042f31b52b9aee45f87a77a5f287b61.tar.bz2
hwids-c88863f56042f31b52b9aee45f87a77a5f287b61.zip
simplify conditional udev logic
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 92f6051..0cbaddd 100644
--- a/Makefile
+++ b/Makefile
@@ -8,17 +8,17 @@ else
endif
PKG_CONFIG ?= pkg-config
-ifeq "$(UDEV)" "yes"
- ALL_TARGETS=compress udev-hwdb
- INSTALL_TARGETS=install-base install-hwdb
-else
- ALL_TARGETS=compress
- INSTALL_TARGETS=install-base
-endif
+UDEV ?= no
+
+ALL_TARGETS-yes = compress
+ALL_TARGETS-$(UDEV) += udev-hwdb
+
+INSTALL_TARGETS-yes = install-base
+INSTALL_TARGETS-$(UDEV) += install-hwdb
-all: $(ALL_TARGETS)
+all: $(ALL_TARGETS-yes)
-install: $(INSTALL_TARGETS)
+install: $(INSTALL_TARGETS-yes)
fetch:
$(Q)curl -z pci.ids -o pci.ids -R http://pci-ids.ucw.cz/v2.2/pci.ids