summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-12-22 21:21:47 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-12-22 21:26:28 +0100
commit804d89ed719e6551d69a1c93ad2f3631f43b2a34 (patch)
tree540b72148fd0e37e3a6a26c2e4cb88b3a21fec6e /app-emulation
parentx11-libs/gtk+: add missing quotes per repoman (diff)
downloadgnome-804d89ed719e6551d69a1c93ad2f3631f43b2a34.tar.gz
gnome-804d89ed719e6551d69a1c93ad2f3631f43b2a34.tar.bz2
gnome-804d89ed719e6551d69a1c93ad2f3631f43b2a34.zip
app-emulation/libvirt-glib: sync with gentoo-x86
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-9999.ebuild40
-rw-r--r--app-emulation/libvirt-glib/metadata.xml10
2 files changed, 33 insertions, 17 deletions
diff --git a/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild b/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
index 0cd2ae07..abbf986d 100644
--- a/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
+++ b/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python gnome2
+inherit gnome2 python-single-r1 vala
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -23,28 +25,32 @@ else
SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-IUSE="doc +introspection python +vala"
+IUSE="+introspection python +vala"
REQUIRED_USE="vala? ( introspection )"
RDEPEND="
dev-libs/libxml2:2
- >=app-emulation/libvirt-0.9.4
+ >=app-emulation/libvirt-0.9.10:=
>=dev-libs/glib-2.10:2
- introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.10 )
- vala? ( dev-lang/vala:0.14 )"
+ vala? ( $(vala_depend) )
+"
pkg_setup() {
- # NEWS, ChangeLog, are empty in git
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
- G2CONF="--disable-test-coverage
- VAPIGEN=$(type -P vapigen-0.14)
- $(use_enable introspection)
- $(use_enable vala)
- $(use_with python)"
+ use python && python-single-r1_pkg_setup
+}
- python_set_active_version 2
- python_pkg_setup
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
}
diff --git a/app-emulation/libvirt-glib/metadata.xml b/app-emulation/libvirt-glib/metadata.xml
new file mode 100644
index 00000000..38f7f9e5
--- /dev/null
+++ b/app-emulation/libvirt-glib/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ <flag name="vala">Enable bindings for <pkg>dev-lang/vala</pkg></flag>
+</use>
+</pkgmetadata>