aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-22 05:18:20 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-22 05:49:51 -0700
commit60d2f9b26ba4cff6782062a7cb1fdb289bd8276e (patch)
tree7ce2b426d5da5e2e2c27e1894258c41254ea460c /bin
parentebump: Add to setup.py, minor update to man page (diff)
downloadgentoolkit-60d2f9b26ba4cff6782062a7cb1fdb289bd8276e.tar.gz
gentoolkit-60d2f9b26ba4cff6782062a7cb1fdb289bd8276e.tar.bz2
gentoolkit-60d2f9b26ba4cff6782062a7cb1fdb289bd8276e.zip
ekeyword: Initial updates for gentoolkit eco-system
Diffstat (limited to 'bin')
-rwxr-xr-xbin/ekeyword45
1 files changed, 45 insertions, 0 deletions
diff --git a/bin/ekeyword b/bin/ekeyword
new file mode 100755
index 0000000..6fb3036
--- /dev/null
+++ b/bin/ekeyword
@@ -0,0 +1,45 @@
+#!/usr/bin/python
+#
+# Copyright 2002-2017 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2 or later
+#
+# $Header$
+
+"""Manage KEYWORDS in ebuilds easily.
+
+This tool provides a simple way to add or update KEYWORDS in a set of ebuilds.
+Each command-line argument is processed in order, so that keywords are added to
+the current list as they appear, and ebuilds are processed as they appear.
+
+"""
+
+from __future__ import print_function
+
+import os
+import sys
+# This block ensures that ^C interrupts are handled quietly.
+try:
+ import signal
+
+ def exithandler(signum,frame):
+ signal.signal(signal.SIGINT, signal.SIG_IGN)
+ signal.signal(signal.SIGTERM, signal.SIG_IGN)
+ print()
+ sys.exit(1)
+
+ signal.signal(signal.SIGINT, exithandler)
+ signal.signal(signal.SIGTERM, exithandler)
+ signal.signal(signal.SIGPIPE, signal.SIG_DFL)
+
+except KeyboardInterrupt:
+ print()
+ sys.exit(1)
+
+from gentoolkit.ekeyword import ekeyword
+
+try:
+ ekeyword.main(sys.argv[1:])
+except KeyboardInterrupt:
+ print("Aborted.")
+ sys.exit(130)
+sys.exit(0)