aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog13
-rw-r--r--Makefile6
-rw-r--r--README2
-rwxr-xr-xbump.sh37
-rw-r--r--etc/conf.d/vdr.shutdown5
-rwxr-xr-xusr/sbin/acpi-wakeup.sh18
-rw-r--r--usr/share/vdr/shutdown/shutdown-reboot.sh4
7 files changed, 74 insertions, 11 deletions
diff --git a/ChangeLog b/ChangeLog
index 1fb5bb7..7adf117 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for gentoo-vdr-scripts
# $Id$
+*gentoo-vdr-scripts-0.4.4 (20 Apr 2008)
+
+ 20 Apr 2008; Matthias Schwarzott <zzam@gentoo.org> Makefile, +bump.sh:
+ Added info make-target. Added bump helper script.
+
+ 20 Apr 2008; Matthias Schwarzott <zzam@gentoo.org>
+ usr/sbin/acpi-wakeup.sh:
+ More baselayout-2 fixes for acpi wakeup. Fixes wrong utc detection.
+
+ 19 Apr 2008; Matthias Schwarzott <zzam@gentoo.org>
+ etc/conf.d/vdr.shutdown, usr/share/vdr/shutdown/shutdown-reboot.sh:
+ Give an explicit name to the automagic reboot handling - auto.
+
19 Apr 2008; Matthias Schwarzott <zzam@gentoo.org>
usr/share/vdr/rcscript/pre-start-45-utf8-check.sh:
Make charmap handling more verbose and fix some export/usage order. Bug
diff --git a/Makefile b/Makefile
index 20156dc..57ef912 100644
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,12 @@ TMPDIR = /tmp
ARCHIVE = gentoo-vdr-scripts-$(VERSION)
PACKAGE = $(ARCHIVE)
+info:
+ @echo VERSION: $(VERSION)
+ @[ -d ../tags/$(VERSION) ] && echo "Already tagged in svn"
+ @echo
+ @[ -d .svn ] && svn info
+
dist:
@-rm -rf $(TMPDIR)/$(ARCHIVE)
@svn export . $(TMPDIR)/$(ARCHIVE)
diff --git a/README b/README
index a17eeed..77428c5 100644
--- a/README
+++ b/README
@@ -1,7 +1,7 @@
README for gentoo-vdr-scripts
$Id$
-Version 0.4.3
+Version 0.4.4
This package contains all support scripts for vdr to make
it like a real set top box.
diff --git a/bump.sh b/bump.sh
new file mode 100755
index 0000000..732ff13
--- /dev/null
+++ b/bump.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+OLDVERS="$(grep '^Version' README | awk '{ print $2 }')"
+NEWVERS="$1"
+
+echo "Updating from $OLDVERS to $NEWVERS"
+
+if [[ "$NEWVERS" == "" ]]; then
+ echo "Please specify new version"
+ exit 1
+fi
+
+if [[ ! -d ../tags/"${OLDVERS}" ]]; then
+ echo "WARNING: Old version $OLDVERS is not tagged"
+fi
+
+if [[ -d ../tags/"${NEWVERS}" ]]; then
+ echo "new version $NEWVERS is already tagged"
+ exit 1
+fi
+
+sed -e "s/^Version.*/Version ${NEWVERS}/" -i README
+
+today=$(LC_ALL=C date +"%d %b %Y")
+
+sed -e "3a\\
+*gentoo-vdr-scripts-${NEWVERS} (${today})\\
+" -i ChangeLog
+
+echo "Commiting bump"
+svn commit -m "Bumped to version ${NEWVERS}" ChangeLog README
+
+
+cd ..
+echo "svn copy"
+svn copy trunk "tags/${NEWVERS}"
+svn commit -m "Tagged version ${NEWVERS}" tags/${NEWVERS}"
+
diff --git a/etc/conf.d/vdr.shutdown b/etc/conf.d/vdr.shutdown
index a677239..7457090 100644
--- a/etc/conf.d/vdr.shutdown
+++ b/etc/conf.d/vdr.shutdown
@@ -90,8 +90,9 @@
#
# Only used for WAKEUP_METHOD nvram when motherboard needs reboot
-# allowed values: lilo grub
-# default: use a special startup-script to shutdown the system, works good but needs a bit more time
+# allowed values: auto grub lilo
+# default: use auto - use a special startup-script, no need to play with boot-managers :)
+#BOOT_MANAGER="auto"
#BOOT_MANAGER="grub"
#
diff --git a/usr/sbin/acpi-wakeup.sh b/usr/sbin/acpi-wakeup.sh
index 8603d87..117c0ac 100755
--- a/usr/sbin/acpi-wakeup.sh
+++ b/usr/sbin/acpi-wakeup.sh
@@ -25,11 +25,13 @@ checkUTC()
{
unset clock
unset CLOCK
- if [ -f /etc/conf.d/clock ]; then
- . /etc/conf.d/clock
- else
- . /etc/rc.conf
- fi
+ local f
+ for f in /etc/conf.d/hwclock /etc/conf.d/clock /etc/rc.conf; do
+ if [ -f "${f}" ]; then
+ . "${f}"
+ break
+ fi
+ done
clock="${clock:-${CLOCK}}"
[ "${clock}" = "UTC" ]
@@ -54,7 +56,11 @@ test $# -ge 1 || die "Wrong Parameter Count"
Next="${1}"
# write time to RTC now, as it may disable wakeup if done after writing alarm time
-/etc/init.d/clock --quiet save
+if [ -x /etc/init.d/hwclock ]; then
+ /etc/init.d/hwclock --quiet save
+else
+ /etc/init.d/clock --quiet save
+fi
if [ "${Next}" -eq 0 ]; then
# This hopefully deactivates wakeup
diff --git a/usr/share/vdr/shutdown/shutdown-reboot.sh b/usr/share/vdr/shutdown/shutdown-reboot.sh
index f570f76..9855096 100644
--- a/usr/share/vdr/shutdown/shutdown-reboot.sh
+++ b/usr/share/vdr/shutdown/shutdown-reboot.sh
@@ -5,11 +5,11 @@
#
if [ -z "${BOOT_MANAGER}" ]; then
- BOOT_MANAGER="none"
+ BOOT_MANAGER="auto"
fi
case "${BOOT_MANAGER}" in
- none)
+ auto)
if [ ! -L /etc/runlevels/boot/wakeup-reboot-halt ]; then
rc-update add wakeup-reboot-halt boot
fi