aboutsummaryrefslogtreecommitdiff
path: root/11.4.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-07 07:30:23 +0000
committerSam James <sam@gentoo.org>2023-01-07 07:30:23 +0000
commit1e0bddd1b980e617230107999f6c7277a8ef5998 (patch)
tree06be5926578018f4eb544ee93fb29f4cf62df5b6 /11.4.0
parent11.4.0: update calloc/musl patch (diff)
downloadgcc-patches-1e0bddd1b980e617230107999f6c7277a8ef5998.tar.gz
gcc-patches-1e0bddd1b980e617230107999f6c7277a8ef5998.tar.bz2
gcc-patches-1e0bddd1b980e617230107999f6c7277a8ef5998.zip
11.4.0: drop upstream 77_all_configure-c89.patch
Now merged upstream. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '11.4.0')
-rw-r--r--11.4.0/gentoo/77_all_configure-c89.patch141
-rw-r--r--11.4.0/gentoo/README.history3
2 files changed, 3 insertions, 141 deletions
diff --git a/11.4.0/gentoo/77_all_configure-c89.patch b/11.4.0/gentoo/77_all_configure-c89.patch
deleted file mode 100644
index 6b297b5..0000000
--- a/11.4.0/gentoo/77_all_configure-c89.patch
+++ /dev/null
@@ -1,141 +0,0 @@
-https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=6be2672e4ee41c566a9e072088cccca263bab5f7
-https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=885b6660c17fb91980b5682514ef54668e544b02
-
-From 942a325c81136138c4c199f8ab3e89a1945c3790 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Tue, 18 Oct 2022 16:58:48 +0200
-Subject: [PATCH 1/2] libsanitizer: Avoid implicit function declaration in
- configure test
-
-libsanitizer/
-
- * configure.ac (sanitizer_supported): Include <unistd.h> for
- syscall prototype.
- * configure: Regenerate.
-
-From 9a43d0e406c05d2d7136721443192bb6588c3113 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Tue, 18 Oct 2022 16:58:48 +0200
-Subject: [PATCH 2/2] libiberty: Fix C89-isms in configure tests
-
-libiberty/
-
- * acinclude.m4 (ac_cv_func_strncmp_works): Add missing
- int return type and parameter list to the definition of main.
- Include <stdlib.h> and <string.h> for prototypes.
- (ac_cv_c_stack_direction): Add missing
- int return type and parameter list to the definitions of
- main, find_stack_direction. Include <stdlib.h> for exit
- prototype.
- * configure: Regenerate.
-
---- a/libiberty/acinclude.m4
-+++ b/libiberty/acinclude.m4
-@@ -24,6 +24,8 @@ AC_CACHE_CHECK([for working strncmp], ac_cv_func_strncmp_works,
- [AC_TRY_RUN([
- /* Test by Jim Wilson and Kaveh Ghazi.
- Check whether strncmp reads past the end of its string parameters. */
-+#include <stdlib.h>
-+#include <string.h>
- #include <sys/types.h>
-
- #ifdef HAVE_FCNTL_H
-@@ -51,7 +53,8 @@ AC_CACHE_CHECK([for working strncmp], ac_cv_func_strncmp_works,
-
- #define MAP_LEN 0x10000
-
--main ()
-+int
-+main (void)
- {
- #if defined(HAVE_MMAP) || defined(HAVE_MMAP_ANYWHERE)
- char *p;
-@@ -157,7 +160,10 @@ if test $ac_cv_os_cray = yes; then
- fi
-
- AC_CACHE_CHECK(stack direction for C alloca, ac_cv_c_stack_direction,
--[AC_TRY_RUN([find_stack_direction ()
-+[AC_TRY_RUN([#include <stdlib.h>
-+
-+int
-+find_stack_direction (void)
- {
- static char *addr = 0;
- auto char dummy;
-@@ -169,7 +175,9 @@ AC_CACHE_CHECK(stack direction for C alloca, ac_cv_c_stack_direction,
- else
- return (&dummy > addr) ? 1 : -1;
- }
--main ()
-+
-+int
-+main (void)
- {
- exit (find_stack_direction() < 0);
- }],
---- a/libiberty/configure
-+++ b/libiberty/configure
-@@ -6774,7 +6774,10 @@ else
- else
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
--find_stack_direction ()
-+#include <stdlib.h>
-+
-+int
-+find_stack_direction (void)
- {
- static char *addr = 0;
- auto char dummy;
-@@ -6786,7 +6789,9 @@ find_stack_direction ()
- else
- return (&dummy > addr) ? 1 : -1;
- }
--main ()
-+
-+int
-+main (void)
- {
- exit (find_stack_direction() < 0);
- }
-@@ -7611,6 +7616,8 @@ else
-
- /* Test by Jim Wilson and Kaveh Ghazi.
- Check whether strncmp reads past the end of its string parameters. */
-+#include <stdlib.h>
-+#include <string.h>
- #include <sys/types.h>
-
- #ifdef HAVE_FCNTL_H
-@@ -7638,7 +7645,8 @@ else
-
- #define MAP_LEN 0x10000
-
--main ()
-+int
-+main (void)
- {
- #if defined(HAVE_MMAP) || defined(HAVE_MMAP_ANYWHERE)
- char *p;
---- a/libsanitizer/configure
-+++ b/libsanitizer/configure
-@@ -16035,6 +16035,7 @@ case "$target" in
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
- #include <sys/syscall.h>
-+#include <unistd.h>
- int
- main ()
- {
---- a/libsanitizer/configure.ac
-+++ b/libsanitizer/configure.ac
-@@ -161,7 +161,8 @@ case "$target" in
- *-*-linux*)
- # Some old Linux distributions miss required syscalls.
- sanitizer_supported=no
-- AC_TRY_COMPILE([#include <sys/syscall.h>],[
-+ AC_TRY_COMPILE([#include <sys/syscall.h>
-+#include <unistd.h>],[
- syscall (__NR_gettid);
- syscall (__NR_futex);
- syscall (__NR_exit_group);
diff --git a/11.4.0/gentoo/README.history b/11.4.0/gentoo/README.history
index c799994..e29c262 100644
--- a/11.4.0/gentoo/README.history
+++ b/11.4.0/gentoo/README.history
@@ -1,3 +1,6 @@
+6 7 Jan 2022
+ - 77_all_configure-c89.patch
+
5 17 Dec 2022
U 29_all_tar_libstdc++-link.patch