summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/app-text/tmispell/tmispell-0.6.3_rc2.ebuild')
-rw-r--r--trunk/app-text/tmispell/tmispell-0.6.3_rc2.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/trunk/app-text/tmispell/tmispell-0.6.3_rc2.ebuild b/trunk/app-text/tmispell/tmispell-0.6.3_rc2.ebuild
deleted file mode 100644
index fa7c188..0000000
--- a/trunk/app-text/tmispell/tmispell-0.6.3_rc2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-MY_PV=${PV/_rc/rc}
-MY_P=${PN}-voikko-${MY_PV}
-
-DESCRIPTION="Tmispell is interface between ispell OO.o Finnish spellcheckers."
-#SRC_URI="mirror://sourceforge/voikko/${MY_P}.tar.gz"
-SRC_URI="http://www.puimula.org/htp/testing/${MY_P}.tar.gz"
-HOMEPAGE="http://voikko.sf.net/"
-IUSE="enchant nls"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="" # release candidate
-
-DEPEND=">=app-text/ispell-3.2.06-r7
- !app-dicts/ispell-fi
- >=app-text/voikko-1.0
- >=dev-libs/glib-2.0.0
- nls? ( sys-devel/gettext )
- sys-apps/coreutils
- sys-devel/bison
- sys-apps/miscfiles
- dev-util/pkgconfig"
-RDEPEND=">=app-text/ispell-3.2.06-r7
- >=app-text/voikko-1.0
- >=dev-libs/glib-2.0.0
- enchant? ( >=app-text/enchant-1.1.6 )
- nls? ( sys-devel/gettext )"
-
-S="${WORKDIR}/${MY_P/rc?/}"
-
-pkg_setup() {
- if [[ -d "${ROOT}/usr/lib/ispell" ]] ; then
- ISPELL_DIR=/usr/lib/ispell
- elif [[ -d "${ROOT}/usr/share/ispell" ]] ; then
- ISPELL_DIR=/usr/share/ispell
- else
- die "Couldn’t find ispell data directory from root ${ROOT}"
- fi
-}
-
-src_compile() {
- econf $(use_enable enchant ) || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog README.fi NEWS README tmispell.conf.example ||\
- die "docs missing"
- insinto /etc/
- newins "${FILESDIR}/tmispell.conf.gentoo" tmispell.conf
- dosym /usr/bin/tmispell /usr/bin/ispell
- dodir ${ISPELL_DIR}
- touch "${D}/${ISPELL_DIR}/"{suomi,finnish}.{hash,aff}
-}
-
-pkg_postinst() {
- if [[ ${ROOT} != "/" ]] ; then
- einfo "If you need to use ispell from different path than "
- einfo " /usr/bin/ispell"
- einfo "you must modify ${ROOT}/etc/tmispell.conf accordingly"
- fi
-}
-
-pkg_postrm() {
- # FIXME: a bit bogus, because it warns on upgrades and whatnot
- if has_version app-text/ispell ; then
- elog "If you are removing tmispell AND leaving ispell you must"
- elog "remerge ispell or do:"
- elog " ln -s ${ROOT}/usr/bin/ispell.real ${ROOT}/usr/bin/ispell "
- elog "for ispell to work"
- fi
-}