diff options
author | volpino <fox91@anche.no> | 2012-05-28 21:16:38 +0200 |
---|---|---|
committer | volpino <fox91@anche.no> | 2012-05-28 21:19:53 +0200 |
commit | b46e9acc08c6cfceffc005f41697434dc0c316f9 (patch) | |
tree | 67be9c90c5fbc69efa7b5452609a1f26acacf83b /setup.py | |
parent | euscanwww: fixed homepage and category validation (diff) | |
download | euscan-b46e9acc08c6cfceffc005f41697434dc0c316f9.tar.gz euscan-b46e9acc08c6cfceffc005f41697434dc0c316f9.tar.bz2 euscan-b46e9acc08c6cfceffc005f41697434dc0c316f9.zip |
euscan: Refactored all management commands
Management commands are refactored to have the logic moved from the
commands themselves to a separated function in order to make them easily
convertible into Celery tasks
Commands are renamed to be modules importable from other python scripts
Signed-off-by: volpino <fox91@anche.no>
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -87,8 +87,9 @@ setup( 'https://github.com/iksaif/euscan/tarball/' + ('master' if __version__ == '9999' else ('euscan-%s' % __version__)) ), - install_requires=['Django==1.4', 'django-annoying', 'South', - 'django-piston', 'BeautifulSoup', "matplotlib"], + install_requires=['Django==1.4', 'django-annoying==0..7.6', 'South==0.7.4', + 'django-piston==0.2.3', 'BeautifulSoup==3.2.1', + 'matplotlib==1.1.0', 'django-celery==2.5.5'], package_dir={'': 'pym'}, packages=packages, package_data={}, |