aboutsummaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
authorMarius Bakke <marius@devup.no>2020-04-09 12:47:44 +0200
committerAnthony G. Basile <blueness@gentoo.org>2020-04-10 09:26:02 -0400
commit941d20bce37b304215817e93e3d98d3018fc847b (patch)
tree8ad04c1ce75c38ec8aabb57d5e8b69ff50ac8ae2 /rules
parentsrc/libudev/libudev-monitor.c: do not check if /dev is tmpfs (diff)
downloadeudev-941d20bce37b304215817e93e3d98d3018fc847b.tar.gz
eudev-941d20bce37b304215817e93e3d98d3018fc847b.tar.bz2
eudev-941d20bce37b304215817e93e3d98d3018fc847b.zip
rules/64-btrfs.rules: Expand @bindir@ to the absolute directory name.
This fixes #182 by ensuring @bindir@ is fully expanded at installation time. See "Installation Directory Variables" in the GNU Autoconf manual, in particular the note about AC_CONFIG_FILES. Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'rules')
-rw-r--r--rules/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/rules/Makefile.am b/rules/Makefile.am
index 4c8758426..6143851a9 100644
--- a/rules/Makefile.am
+++ b/rules/Makefile.am
@@ -43,5 +43,11 @@ dist_udevrules_DATA += \
75-probe_mtd.rules
endif
+do_subst = $(SED) \
+ -e 's,[@]bindir[@],$(bindir),g'
+
+64-btrfs.rules: 64-btrfs.rules.in Makefile
+ $(do_subst) < $< > $@
+
install-data-local:
$(MKDIR_P) $(DESTDIR)$(udevconfdir)/rules.d