summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-12-10 20:09:20 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-12-10 20:09:20 -0500
commit9716aae78b821f26f3b820d838cec65d0b73c408 (patch)
treee5f4b215600544be5ebeead3e3ce5fbc9957d281
parentBump version to 0.8.1 in configure.ac. (diff)
downloadeselect-php-9716aae78b821f26f3b820d838cec65d0b73c408.tar.gz
eselect-php-9716aae78b821f26f3b820d838cec65d0b73c408.tar.bz2
eselect-php-9716aae78b821f26f3b820d838cec65d0b73c408.zip
Use AC_PROG_MKDIR_P macro/variable instead of "mkdir -p".
-rw-r--r--configure.ac1
-rw-r--r--src/php.eselect.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d892d13..aa7bf70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,6 +2,7 @@ AC_INIT([eselect-php], [0.8.1])
AM_INIT_AUTOMAKE([-Wall foreign no-dist-gzip dist-xz])
AC_PROG_LN_S
+AC_PROG_MKDIR_P
AC_PROG_SED
AC_PATH_PROG(SORT,sort)
AC_PATH_PROG(UNIQ,uniq)
diff --git a/src/php.eselect.in b/src/php.eselect.in
index aa8ad68..7e918ab 100644
--- a/src/php.eselect.in
+++ b/src/php.eselect.in
@@ -227,7 +227,7 @@ write_mod_php_conf() {
local conf_dir="${EROOT}"/var/lib/eselect-php
local conf_path="${conf_dir}/mod_php.conf"
- mkdir -p "${conf_dir}" || die "failed to create ${conf_dir}"
+ @MKDIR_P@ "${conf_dir}" || die "failed to create ${conf_dir}"
# Parse the major version (for example "5" or "7") out of the
# target name.