summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-02-09 20:46:25 +0000
committerThomas Sachau <tommy@gentoo.org>2014-02-09 20:46:25 +0000
commitdb567745bc99e0da4c39d842bd3bf98cde2bec63 (patch)
tree32bb6f856c327ffb980c923ce049e4cf8e203eea
parentVersion bump (diff)
downloadenlightenment-db567745bc99e0da4c39d842bd3bf98cde2bec63.tar.gz
enlightenment-db567745bc99e0da4c39d842bd3bf98cde2bec63.tar.bz2
enlightenment-db567745bc99e0da4c39d842bd3bf98cde2bec63.zip
Version bump
-rw-r--r--x11-wm/enlightenment/Manifest1
-rw-r--r--x11-wm/enlightenment/enlightenment-0.18.3.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
index 9ae45cc..b783ca9 100644
--- a/x11-wm/enlightenment/Manifest
+++ b/x11-wm/enlightenment/Manifest
@@ -1 +1,2 @@
DIST enlightenment-0.18.2.tar.bz2 27617865 SHA256 a481cccc83c638aeb0b4ae5e0a34ae5cf1cbf366df26a2a6d4378dc2ad02e28e SHA512 ef5858eb081430537611d041a1ea5c264102711008bc2ffe18c841937cdb54cbf999e09020a4559c0f724a7deee4244906f2479d2a8107956be8b04c5ac5cd94 WHIRLPOOL b708b88ace2b229bd2b9cd045821bb36496e428447a03d2591f0ee7b9d2e57fc736b78c06278633105cc0a7b549e3bb8483cfb4bc3f5f6a3f6ba3df673a5e665
+DIST enlightenment-0.18.3.tar.bz2 27598857 SHA256 c8f269c0e1d02fdcd5ed74576056a14485ff8ed51b131f1b252faddd2fb66773 SHA512 36b02427bf3058988e467a5d6e52e151583928c231cb5317e6d8516cbdcaaca8b22e1cc4a7a9ffb30946f46d5754e9d77c0f62c2255233be429a36bed136dba1 WHIRLPOOL eaf25f8548f0d2813fa31c4b5c7267f62a0d2105c3bba193a10dd6d0fc4f88364d558b49ade7d16431b51b9d5952fc57b664b301ae6513d496c39e35f7727611
diff --git a/x11-wm/enlightenment/enlightenment-0.18.3.ebuild b/x11-wm/enlightenment/enlightenment-0.18.3.ebuild
new file mode 100644
index 0000000..1b35b9b
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.18.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.17.5_pre2.ebuild,v 1.1 2013/10/04 10:40:51 tommy Exp $
+
+EAPI=5
+
+MY_P=${P/_/-}
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="http://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0.17/${PV%%_*}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@comp +@dialogs +@display
+ +@interaction +@intl +@menus
+ +@paths +@performance +@randr +@shelves +@theme +@wallpaper2
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@appmenu +@backlight +@bluez4 +@battery +@clock
+ +@connman +@contact +@cpufreq +@everything +@fileman
+ +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2 +@mixer +@msgbus
+ +@music-control +@notification +@pager +@quickaccess +@shot
+ +@start +@syscon +@systray +@tasks +@teamwork +@temperature +@tiling
+ +@winlist +@wizard @wl-desktop-shell @wl-screenshot +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="pam spell static-libs systemd +udev ukit wayland ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ wayland? ( dev-libs/efl[wayland]
+ >=dev-libs/wayland-1.2.0
+ >=x11-libs/pixman-0.31.1
+ >=x11-libs/libxkbcommon-0.3.1
+ )
+ >=dev-libs/efl-1.8.3
+ || ( >=dev-libs/efl-1.8.3[X] >=dev-libs/efl-1.8.3[xcb] )
+ >=media-libs/elementary-1.8.2
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ E_ECONF+=(
+ --disable-install-sysactions
+ $(use_enable doc)
+ --disable-device-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ $(use_enable systemd)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ $(use_enable wayland wayland-clients)
+ )
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}