aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgpg-error/libgpg-error-1.7.ebuild')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.7.ebuild b/dev-libs/libgpg-error/libgpg-error-1.7.ebuild
new file mode 100644
index 0000000..c779178
--- /dev/null
+++ b/dev-libs/libgpg-error/libgpg-error-1.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.7.ebuild,v 1.8 2009/05/22 14:33:15 armin76 Exp $
+
+inherit libtool eutils autotools
+
+DESCRIPTION="Contains error handling functions used by GnuPG software"
+HOMEPAGE="http://www.gnupg.org/related_software/libgpg-error"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Add pkg-config support to this package
+ # (for easier cross-compilation).
+ epatch "${FILESDIR}/${PN}-pkgconfig-support.patch"
+
+ eautoreconf
+
+ # for BSD?
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable nls)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}