aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-18 11:05:04 +0000
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-18 11:05:04 +0000
commit3f4a1d3e593b33bad30aa6aacfdedc25bf2d1468 (patch)
tree99d2aa0e004ccb39e0e66aeddfe92a7138675487 /x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild
parentbig cleanup commit, if I broke smth for somebody - sorry (diff)
downloadembedded-cross-3f4a1d3e593b33bad30aa6aacfdedc25bf2d1468.tar.gz
embedded-cross-3f4a1d3e593b33bad30aa6aacfdedc25bf2d1468.tar.bz2
embedded-cross-3f4a1d3e593b33bad30aa6aacfdedc25bf2d1468.zip
rollback changeset r235
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild
new file mode 100644
index 0000000..b84cd57
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.1.3.ebuild,v 1.1 2009/02/26 07:51:28 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.5.3
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}