aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-12 10:36:30 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-12 10:36:30 +0000
commit8d0099d7b8492f429e0d66b3eabccc09f78dfba0 (patch)
treebee03c6507751af951307936c49aa55854a05b93 /sys-apps
parentfix coreutils-7.4 (diff)
downloadembedded-cross-8d0099d7b8492f429e0d66b3eabccc09f78dfba0.tar.gz
embedded-cross-8d0099d7b8492f429e0d66b3eabccc09f78dfba0.tar.bz2
embedded-cross-8d0099d7b8492f429e0d66b3eabccc09f78dfba0.zip
This fixes ticket #205. Thanks to arussello for the patch!
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/Manifest2
-rw-r--r--sys-apps/dbus/dbus-1.2.12.ebuild139
2 files changed, 141 insertions, 0 deletions
diff --git a/sys-apps/dbus/Manifest b/sys-apps/dbus/Manifest
index d514c9f..84c6ab3 100644
--- a/sys-apps/dbus/Manifest
+++ b/sys-apps/dbus/Manifest
@@ -2,5 +2,7 @@ AUX 30-dbus 243 RMD160 b5e7a813cd5d91f2ea60bb22260e432cbfb72fd9 SHA1 35ee3a5d3db
AUX dbus-1.2.3-bsd.patch 1638 RMD160 9a134c5e1ccc1215d0579a02568a5707ad39e484 SHA1 061787f8131f33ccf07f11e04e6a327372de1c69 SHA256 0428d70451344153c6bf44f12d04fb7732070abf44d0d162ad995de5a9a24f1e
AUX dbus-1.2.3-panic-from-dbus_signature_validate.patch 1064 RMD160 a7a587fb604f94f8d064c21d0adfae080edc1a80 SHA1 309faf628e3a207985c79afd2789b8cce696eed6 SHA256 455e2834b71878b3ea1ff9f0b678c8890b2c25f0c309c96c4a8e5551e23bca68
AUX dbus.init-1.0 1152 RMD160 f0f409b59167beef2e2b8c14f701fbeaa54c3bc9 SHA1 b00e23868046c67eaec87220e92ffcea5d9dd911 SHA256 a2e13a025faa488ff35521188c0d44909bc82c55e8676a24a5a5179545303d98
+DIST dbus-1.2.12.tar.gz 1574756 RMD160 779d76320f1343dae7447c82a683e372e6c11729 SHA1 13de8dc28c9edae7b9d2928ff691549bb2bef21a SHA256 b2ec81e7d9fa5e24f67baccfd9af2755a7797a65cb4c3cad10d023867f2bd220
DIST dbus-1.2.3.tar.gz 1564475 RMD160 d1a207b2a4c744f27c9c01388e80cebdb61f43f0 SHA1 ceb8d496bc1a9c2dcdbe559515c01ec9c0cdcf81 SHA256 16ffaa4a8758f115cf02c78962b0849ed4d802872420fd460c433a9cd580ed1a
+EBUILD dbus-1.2.12.ebuild 4040 RMD160 f33351b5c8725760cfcf50ded1f4ed2a8a802df2 SHA1 c99b12b72c9deb44d91c3cab8b06fff4396fd2b1 SHA256 9b0c7864ab3f8b184aef523e078556a3d911ad5eb9e77d273e4ab9e2fb471675
EBUILD dbus-1.2.3-r1.ebuild 3913 RMD160 037c5b6fa0382a69c6f08d17637c48eefbb1fc8d SHA1 9e86c1e8bc4383cdb8b0b5b39e10144575397c2a SHA256 138725b1db699679c06eae0c5fcb1e11e7fdb476f537260dc74a3aae2a052558
diff --git a/sys-apps/dbus/dbus-1.2.12.ebuild b/sys-apps/dbus/dbus-1.2.12.ebuild
new file mode 100644
index 0000000..e4274a8
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.2.12.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.2.12.ebuild,v 1.3 2009/04/23 05:46:44 nirbheek Exp $
+
+inherit eutils multilib flag-o-matic autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc selinux test X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux
+ sec-policy/selinux-dbus )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )
+ X? ( x11-libs/libSM )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Tests were restricted because of this
+ sed -e 's/.*bus_dispatch_test.*/printf ("Disabled due to excess noise\\n");/' \
+ -e '/"dispatch"/d' -i "${S}/bus/test-main.c"
+
+ # We need to do the autoconf/automake magic because otherwise
+ # cross-compilation will fail due to a wrong sys_lib_search_path_spec.
+ eautoreconf
+}
+
+src_compile() {
+ # so we can get backtraces from apps
+ append-flags -rdynamic
+
+ # libaudit is *only* used in DBus wrt SELinux support, so disable it, if
+ # not on an SELinux profile.
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable selinux libaudit) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ $(use_enable test tests) \
+ $(use_enable test asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-1.0 dbus
+
+ if use X ; then
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+ fi
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+ # needs to exist for dbus sessions to launch
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+ keepdir /etc/dbus-1/system.d/
+ keepdir /etc/dbus-1/session.d/
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus
+ enewuser messagebus -1 "-1" -1 messagebus
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog
+ elog "Some applications require a session bus in addition to the system"
+ elog "bus. Please see \`man dbus-launch\` for more information."
+ elog
+ elog
+ ewarn "You MUST run 'revdep-rebuild' after emerging this package"
+ elog
+ ewarn "You must restart D-Bus \`/etc/init.d/dbus restart\` to run"
+ ewarn "the new version of the daemon."
+
+ if has_version x11-base/xorg-server && built_with_use x11-base/xorg-server hal; then
+ elog
+ ewarn "You are currently running X with the hal useflag enabled"
+ ewarn "restarting the dbus service WILL restart X as well"
+ ebeep 5
+ fi
+
+ if use test; then
+ elog
+ ewarn "You have unit tests enabled, this results in an insecure library"
+ ewarn "It is recommended that you reinstall *without* FEATURES=test"
+ fi
+}