aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'tests/pxtpax/Makefile.am')
-rw-r--r--tests/pxtpax/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/pxtpax/Makefile.am b/tests/pxtpax/Makefile.am
index 4770a08..55f9957 100644
--- a/tests/pxtpax/Makefile.am
+++ b/tests/pxtpax/Makefile.am
@@ -1,7 +1,12 @@
noinst_PROGRAMS = daemon
daemon_SOURCES = daemon.c
-EXTRA_DIST = init.sh test.sh
+EXTRA_DIST = init.sh dotest.sh
check_SCRIPTS = test.sh
TEST = $(check_SCRIPTS)
+
+test.sh:
+ ./dotest.sh
+
+CLEANFILES = daemon.pid