summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2011-08-12 21:13:08 +0200
committerSebastian Pipping <sebastian@pipping.org>2011-08-12 21:44:41 +0200
commit4272ead7bcb4ff93307d91fa959e57a69f39c8ce (patch)
tree0df66553354bd0f967c1b7f9c6ea288f8b2af9b6 /x11-libs
parentdev-libs/atk: 2.1.0 (diff)
downloadbetagarden-4272ead7bcb4ff93307d91fa959e57a69f39c8ce.tar.gz
betagarden-4272ead7bcb4ff93307d91fa959e57a69f39c8ce.tar.bz2
betagarden-4272ead7bcb4ff93307d91fa959e57a69f39c8ce.zip
x11-libs/gtk+: 3.1.10
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/gtk+-3.1.10.ebuild199
2 files changed, 201 insertions, 0 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index f77b0e9..18330cf 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,3 +1,5 @@
AUX settings.ini 96 RMD160 ff8d7e28f097820b15ea1d2168d9405db1a5707b SHA1 92c3120655ba14f163846a22d5c94fa50b0eb437 SHA256 a42c86c26b5bfa0da806961e28cdff21da6e2f7c35febf67c67d7f2667658163
+DIST gtk+-3.1.10.tar.xz 12655956 RMD160 122e44b98f0a199eaef8a453ff2b1bdf90490c32 SHA1 caec204650bb01178cbabab2d304c3f8787f3eee SHA256 976e90b97e978aecce988984eef04cb4a44720a3ddf863ee2b169f056fb91580
DIST gtk+-3.1.6.tar.xz 12652144 RMD160 1bfb6064d76595f143fef3f1f14fa0f7d9647a32 SHA1 6b0f2f55194e8e6232a61928257494d520b4b084 SHA256 8a541225137910b41fa11d2d4856d934cee550c0ce1db6d2b7b6f967b8a5dfea
+EBUILD gtk+-3.1.10.ebuild 5806 RMD160 760decb351c74c2cd0b6022ecb4eb5d6d968f66d SHA1 a1fb2f899b35db416dda199171304ca7698645d9 SHA256 822df914c1e0639e6ec435373bace141e84b551eddf4523919b7585a0af516eb
EBUILD gtk+-3.1.6.ebuild 5748 RMD160 cd6c352e447038b089b3b26bfc354aa75ecb6c3b SHA1 5a2f18393a93c92d787687f65e6283130a010c65 SHA256 3322b188d8c100bdb3ff2c59939bf56f98bbf17ff7625f9540d371a202e00941
diff --git a/x11-libs/gtk+/gtk+-3.1.10.ebuild b/x11-libs/gtk+/gtk+-3.1.10.ebuild
new file mode 100644
index 0000000..9acc43a
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.1.10.ebuild
@@ -0,0 +1,199 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit eutils flag-o-matic gnome.org gnome2-utils libtool virtualx
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="3"
+# NOTE: *-macos support is BROKEN. See `quartz-backend` etc in configure
+# NOTE: This gtk+ has multi-gdk-backend support, see:
+# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
+# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
+# NOTE: Lots of aqua stuff in this ebuild is probably very broken
+IUSE="aqua colord cups debug doc examples +introspection packagekit test vim-syntax xinerama"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="" # due to deps with KEYWORDS=""
+fi
+
+# FIXME: introspection data is built against system installation of gtk+:3
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+# Use gtk+:2 for gtk-update-icon-cache and gtk-builder-convert
+# >=x11-libs/gtk+-2.24:2 is needed for bug 359555
+COMMON_DEPEND="!aqua? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ >=x11-libs/cairo-1.10.0[X,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[X,introspection?]
+ )
+ aqua? (
+ >=x11-libs/cairo-1.10.0[aqua,svg]
+ >=x11-libs/gdk-pixbuf-2.22.0:2[introspection?]
+ )
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.29.14
+ >=x11-libs/pango-1.29.0[introspection?]
+ >=dev-libs/atk-2.1.0[introspection?]
+ >=x11-libs/gtk+-2.24:2
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ colord? ( >=x11-misc/colord-0.1.9 )
+ cups? ( net-print/cups )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ !aqua? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ )
+ x86-interix? (
+ sys-libs/itx-bind
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ packagekit? ( app-admin/packagekit-base )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+ sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
+ -i gtk/tests/recentmanager.c || die "sed 2 failed"
+
+ if use x86-interix; then
+ # activate the itx-bind package...
+ append-flags "-I${EPREFIX}/usr/include/bind"
+ append-ldflags "-L${EPREFIX}/usr/lib/bind"
+ fi
+
+ if ! use test; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS tests Makefile.am
+ [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS tests Makefile.in
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am
+ [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS demos Makefile.in
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc)
+ $(use_enable xinerama)
+ $(use_enable packagekit)
+ $(use_enable cups cups auto)
+ $(use_enable colord)
+ $(use_enable introspection)
+ --disable-papi
+ --enable-gtk2-dependency"
+
+ # XXX: Maybe with multi-backend we should enable x11 all the time?
+ if use aqua; then
+ myconf="${myconf} --enable-quartz-backend --disable-xinput"
+ else
+ myconf="${myconf} --enable-x11-backend --enable-xinput"
+ fi
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Exporting HOME fixes tests using XDG directories spec since all defaults
+ # are based on $HOME. It is also backward compatible with functions not
+ # yet ported to this spec.
+ XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > "${T}/gtkrc"
+ insinto /etc/gtk-3.0
+ doins "${T}"/gtkrc || die "doins gtkrc failed"
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README* || die "dodoc failed"
+
+ # Remove unneeded *.la files
+ find "${ED}" -name "*.la" -delete
+
+ # add -framework Carbon to the .pc files
+ use aqua && for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
+ sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+ done
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ local GTK3_MODDIR="${EROOT}usr/$(get_libdir)/gtk-3.0/3.0.0"
+ gtk-query-immodules-3.0 > "${GTK3_MODDIR}/immodules.cache" \
+ || ewarn "Failed to run gtk-query-immodules-3.0"
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your gtkrc."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_schemas_update --uninstall
+}