summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-15 13:02:57 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-20 08:07:04 +0100
commit542c24b4942da8fa5418b9319a4ab5da109cbd59 (patch)
treea1fa5a7d2da134747f148dee72ebcb5b79dfd6ab /dev-vcs
parentapp-misc/info-beamer: 1.0_pre3_p20140107 (diff)
downloadbetagarden-542c24b4942da8fa5418b9319a4ab5da109cbd59.tar.gz
betagarden-542c24b4942da8fa5418b9319a4ab5da109cbd59.tar.bz2
betagarden-542c24b4942da8fa5418b9319a4ab5da109cbd59.zip
dev-vcs/git-cola: Import tree changes; bump to git-r3.eclass
Package-Manager: portage-2.2.8
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/ChangeLog8
-rw-r--r--dev-vcs/git-cola/files/git-cola-9999-disable-tests.patch21
-rw-r--r--dev-vcs/git-cola/files/git-cola-9999-system-ssh-askpass.patch (renamed from dev-vcs/git-cola/files/9999-system-ssh-askpass.patch)0
-rw-r--r--dev-vcs/git-cola/git-cola-9999.ebuild14
4 files changed, 35 insertions, 8 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index 74b4612..f821c61 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-vcs/git-cola
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.8 2011/04/13 19:00:02 jlec Exp $
+ 15 Jan 2014; Justin Lecher <jlec@gentoo.org> git-cola-9999.ebuild,
+ -files/9999-system-ssh-askpass.patch,
+ +files/git-cola-9999-disable-tests.patch,
+ +files/git-cola-9999-system-ssh-askpass.patch:
+ Import tree changes; bump to git-r3.eclass
+
23 Oct 2013; Justin Lecher <jlec@gentoo.org> git-cola-9999.ebuild:
Update to latest HEAD
diff --git a/dev-vcs/git-cola/files/git-cola-9999-disable-tests.patch b/dev-vcs/git-cola/files/git-cola-9999-disable-tests.patch
new file mode 100644
index 0000000..79f1ec2
--- /dev/null
+++ b/dev-vcs/git-cola/files/git-cola-9999-disable-tests.patch
@@ -0,0 +1,21 @@
+diff -Naur cola-1.3.7.21.orig/test/git_test.py cola-1.3.7.21/test/git_test.py
+--- cola-1.3.7.21.orig/test/git_test.py 2009-04-30 13:56:22.352319047 +0200
++++ cola-1.3.7.21/test/git_test.py 2009-04-30 13:56:53.123149963 +0200
+@@ -24,17 +24,6 @@
+ version = self.git.version()[STDOUT]
+ self.failUnless(version.startswith('git version'))
+
+- def test_tag(self):
+- """Test running 'git tag'"""
+- tags = self.git.tag()[STDOUT].splitlines()
+- self.failUnless( 'v1.0.0' in tags )
+-
+- def test_show(self):
+- """Test running 'git show'"""
+- sha = '1b9742bda5d26a4f250fa64657f66ed20624a084'
+- contents = self.git.show(sha)[STDOUT].splitlines()
+- self.failUnless(contents[0] == '/build')
+-
+ def test_stdout(self):
+ """Test overflowing the stdout buffer"""
+ # Write to stdout only
diff --git a/dev-vcs/git-cola/files/9999-system-ssh-askpass.patch b/dev-vcs/git-cola/files/git-cola-9999-system-ssh-askpass.patch
index 0aa476f..0aa476f 100644
--- a/dev-vcs/git-cola/files/9999-system-ssh-askpass.patch
+++ b/dev-vcs/git-cola/files/git-cola-9999-system-ssh-askpass.patch
diff --git a/dev-vcs/git-cola/git-cola-9999.ebuild b/dev-vcs/git-cola/git-cola-9999.ebuild
index 9669e48..2aa4631 100644
--- a/dev-vcs/git-cola/git-cola-9999.ebuild
+++ b/dev-vcs/git-cola/git-cola-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/cola-1.4.3.2.ebuild,v 1.1 2011/04/13 19:00:02 jlec Exp $
+# $Header: $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
DISTUTILS_SINGLE_IMPL=true
-inherit distutils-r1 git-2
+inherit distutils-r1 git-r3
DESCRIPTION="The highly caffeinated git GUI"
HOMEPAGE="http://git-cola.github.com/"
@@ -26,14 +26,14 @@ RDEPEND="
dev-vcs/git"
DEPEND="${RDEPEND}
app-text/asciidoc
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- app-text/xmlto )
+ app-text/xmlto
sys-devel/gettext
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
PATCHES=(
- "${FILESDIR}"/${PV}-system-ssh-askpass.patch
+ "${FILESDIR}"/${P}-disable-tests.patch
+ "${FILESDIR}"/${P}-system-ssh-askpass.patch
)
python_prepare_all() {