aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdhemerval Zanella <adhemerval.zanella@linaro.org>2016-12-05 18:32:11 -0200
committerAdhemerval Zanella <adhemerval.zanella@linaro.org>2018-07-24 14:07:25 -0300
commit0a07288b13c89dbbb1cac964891f5905a0919434 (patch)
treef9e442adfc943afb4ea1d5ef3a0062b5ac6190f2 /nptl/tst-tss-basic.c
parentnptl: Add abilist symbols for C11 threads (diff)
downloadglibc-0a07288b13c89dbbb1cac964891f5905a0919434.tar.gz
glibc-0a07288b13c89dbbb1cac964891f5905a0919434.tar.bz2
glibc-0a07288b13c89dbbb1cac964891f5905a0919434.zip
nptl: Add test cases for ISO C11 threads
This patch adds to testsuite new test cases to test all new introduced C11 threads functions, types and macros are tested. Checked with a build for all major ABI (aarch64-linux-gnu, alpha-linux-gnu, arm-linux-gnueabi, i386-linux-gnu, ia64-linux-gnu, m68k-linux-gnu, microblaze-linux-gnu [1], mips{64}-linux-gnu, nios2-linux-gnu, powerpc{64le}-linux-gnu, s390{x}-linux-gnu, sparc{64}-linux-gnu, and x86_64-linux-gnu). Also ran a full check on aarch64-linux-gnu, x86_64-linux-gnu, i686-linux-gnu, arm-linux-gnueabhf, and powerpc64le-linux-gnu. Adhemerval Zanella <adhemerval.zanella@linaro.org> Juan Manuel Torres Palma <jmtorrespalma@gmail.com> [BZ #14092] * nptl/Makefile (tests): Add new test files. * nptl/tst-call-once.c : New file. Tests C11 functions and types. * nptl/tst-cnd-basic.c: Likewise. * nptl/tst-cnd-broadcast.c: Likewise. * nptl/tst-cnd-timedwait.c: Likewise. * nptl/tst-mtx-basic.c: Likewise. * nptl/tst-mtx-recursive.c: Likewise. * nptl/tst-mtx-timedlock.c: Likewise. * nptl/tst-mtx-trylock.c: Likewise. * nptl/tst-thrd-basic.c: Likewise. * nptl/tst-thrd-detach.c: Likewise. * nptl/tst-thrd-sleep.c: Likewise. * nptl/tst-tss-basic.c: Likewise.
Diffstat (limited to 'nptl/tst-tss-basic.c')
-rw-r--r--nptl/tst-tss-basic.c75
1 files changed, 75 insertions, 0 deletions
diff --git a/nptl/tst-tss-basic.c b/nptl/tst-tss-basic.c
new file mode 100644
index 0000000000..e82edadfbe
--- /dev/null
+++ b/nptl/tst-tss-basic.c
@@ -0,0 +1,75 @@
+/* C11 threads specific storage tests.
+ Copyright (C) 2018 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+ The GNU C Library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ The GNU C Library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with the GNU C Library; if not, see
+ <http://www.gnu.org/licenses/>. */
+
+#include <threads.h>
+#include <stdio.h>
+#include <unistd.h>
+
+#include <support/check.h>
+
+/* Thread specific storage. */
+static tss_t key;
+
+#define TSS_VALUE (void*) 0xFF
+
+static int
+tss_thrd (void *arg)
+{
+ if (tss_create (&key, NULL) != thrd_success)
+ FAIL_EXIT1 ("tss_create failed");
+
+ if (tss_set (key, TSS_VALUE))
+ FAIL_EXIT1 ("tss_set failed");
+
+ void *value = tss_get (key);
+ if (value == 0)
+ FAIL_EXIT1 ("tss_get failed");
+ if (value != TSS_VALUE)
+ FAIL_EXIT1 ("tss_get returned %p, expected %p", value, TSS_VALUE);
+
+ thrd_exit (thrd_success);
+}
+
+static int
+do_test (void)
+{
+ /* Setting an invalid key should return an error. */
+ if (tss_set (key, TSS_VALUE) == thrd_success)
+ FAIL_EXIT1 ("tss_set succeed where it should have failed");
+
+ if (tss_create (&key, NULL) != thrd_success)
+ FAIL_EXIT1 ("tss_create failed");
+
+ thrd_t id;
+ if (thrd_create (&id, tss_thrd, NULL) != thrd_success)
+ FAIL_EXIT1 ("thrd_create failed");
+
+ if (thrd_join (id, NULL) != thrd_success)
+ FAIL_EXIT1 ("thrd failed");
+
+ /* The value set in tss_thrd should not be visible here. */
+ void *value = tss_get (key);
+ if (value != 0)
+ FAIL_EXIT1 ("tss_get succeed where it should have failed");
+
+ tss_delete (key);
+
+ return 0;
+}
+
+#include <support/test-driver.c>